New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #34152 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

openssl broken after upgrade to 1.0.1a on PPC Leopard

Reported by: frank.kahle@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: PPC Leopard Cc: hosseini@…
Port: openssl

Description

Dear all,

openssl fails to build on PPC Leopard:

:info:build make[2]: Leaving directory `/opt/ppc/var/macports/build/_opt_ppc_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_openssl/openssl/work/openssl-1.0.1a/crypto/cmac' :info:build if [ -n "libcrypto.1.0.0.dylib libssl.1.0.0.dylib" ]; then \ :info:build (cd ..; /usr/bin/make libcrypto.1.0.0.dylib); \ :info:build fi :info:build make[2]: Entering directory `/opt/ppc/var/macports/build/_opt_ppc_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_openssl/openssl/work/openssl-1.0.1a'

:info:build [ -z "" ]
/Developer/usr/bin/llvm-gcc-4.2 -fPIC -fno-common -DOPENSSL_PIC -DZLIB -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -arch ppc -O3 -DB_ENDIAN -Wa,-force_cpusubtype_ALL -Iinclude \

:info:build -DFINGERPRINT_PREMAIN_DSO_LOAD -o fips_premain_dso \ :info:build fips_premain.c fipscanister.o \ :info:build libcrypto.a -L/opt/ppc/lib -lz :info:build make[3]: Entering directory `/opt/ppc/var/macports/build/_opt_ppc_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_openssl/openssl/work/openssl-1.0.1a' :info:build make[4]: Entering directory `/opt/ppc/var/macports/build/_opt_ppc_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_openssl/openssl/work/openssl-1.0.1a' :info:build Undefined symbols: :info:build "_OPENSSL_ia32cap_P", referenced from: :info:build _OPENSSL_ia32cap_P$non_lazy_ptr in libcrypto.a(e_rc4_hmac_md5.o) :info:build ld: symbol(s) not found :info:build collect2: ld returned 1 exit status

Kind regards, Frank

Change History

comment:1 Changed 2 years ago by dluke@…

  • Status changed from new to closed
  • Resolution set to duplicate

It's actually the upgrade to 1.0.1a that broke this (and this is a dupe of #34135)

comment:2 Changed 2 years ago by dluke@…

  • Summary changed from openssl broken after upgrade to 1.0.1 on PPC Leopard to openssl broken after upgrade to 1.0.1a on PPC Leopard

comment:3 Changed 2 years ago by hosseini@…

  • Cc hosseini@… added

Cc Me!

Note: See TracTickets for help on using tickets.