Opened 5 years ago

Closed 5 years ago

#34154 closed defect (fixed)

kdevplatform @1.3.1 fails to build: Undefined symbols "KDevelop::IPlugin::extensions() const"

Reported by: blixa@… Owned by: NicosPavlov
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: lion Cc: gregory.verret@…
Port: kdevplatform


I got the following linker error when compiling kdevplatform on OSX Lion 10.7.3/Xcode 4.3.2

I think the symbols can't be found in libkdevplatforminterfaces.5.0.0.dylib, but libkdevplatforminterfaces.5.0.0.dylib build fine

:info:build /usr/bin/llvm-g++-4.2  -pipe -O2 -arch x86_64  -fno-common -Woverloaded-virtual -fvisibility=hidden -Werror=return-type -fvisibility-inlines-hidden -O2 -DNDEBUG -DQT_NO_DEBUG -arch x86_64 -isysroot / -mmacosx-version-min=10.7 -dynamiclib -Wl,-headerpad_max_install_names -single_module -multiply_defined suppress  -arch x86_64 -compatibility_version 5.0.0 -current_version 5.0.0 -o ../lib/libkdevplatformoutputview.5.0.0.dylib -install_name /opt/local/lib/libkdevplatformoutputview.5.dylib CMakeFiles/kdevplatformoutputview.dir/kdevplatformoutputview_automoc.o CMakeFiles/kdevplatformoutputview.dir/outputmodel.o CMakeFiles/kdevplatformoutputview.dir/ioutputview.o CMakeFiles/kdevplatformoutputview.dir/ioutputviewmodel.o CMakeFiles/kdevplatformoutputview.dir/outputjob.o -L/opt/local/lib -L/opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org_trunk_dports_kde_kdevplatform/kdevplatform/work/build/lib /opt/local/lib/libQtCore.dylib -lpthread /opt/local/lib/libkdeui.5.8.0.dylib ../lib/libkdevplatforminterfaces.5.0.0.dylib /opt/local/lib/libktexteditor.4.8.0.dylib /opt/local/lib/libkparts.4.8.0.dylib /opt/local/lib/libkio.5.8.0.dylib /opt/local/lib/libnepomukutils.4.8.0.dylib /opt/local/lib/libQtNetwork.dylib /opt/local/lib/libnepomuk.4.8.0.dylib /opt/local/lib/libsoprano.dylib /opt/local/lib/libkdeui.5.8.0.dylib /opt/local/lib/libQtGui.dylib /opt/local/lib/libQtSvg.dylib /opt/local/lib/libkdecore.5.8.0.dylib /opt/local/lib/libQtCore.dylib -lpthread /opt/local/lib/libQtDBus.dylib -framework Carbon /opt/local/lib/libQtXml.dylib 
:info:build Undefined symbols for architecture x86_64:
:info:build   "KDevelop::IPlugin::extensions() const", referenced from:
:info:build       KDevelop::IOutputView* KDevelop::IPlugin::extension<KDevelop::IOutputView>()in outputjob.o
:info:build   "KDevelop::ICore::self()", referenced from:
:info:build       KDevelop::OutputJob::startOutput()     in outputjob.o
:info:build ld: symbol(s) not found for architecture x86_64
:info:build collect2: ld returned 1 exit status
:info:build make[2]: *** [lib/libkdevplatformoutputview.5.0.0.dylib] Error 1

Attachments (3)

kdevplatform_main.log (2.9 MB) - added by jwhowse4 5 years ago.
language-editor-modificationrevision.cpp.diff (389 bytes) - added by blixa@… 5 years ago.
Portfile (1.5 KB) - added by blixa@… 5 years ago.

Change History (10)

comment:1 Changed 5 years ago by jwhowse4

I have the same system configuration and I believe I am having the same problem. I have attached the log file for my failed build.

Changed 5 years ago by jwhowse4

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

  • Owner changed from macports-tickets@… to nicos@…

comment:3 Changed 5 years ago by gregory.verret@…

  • Cc gregory.verret@… added

Cc Me!

comment:4 follow-up: Changed 5 years ago by gregory.verret@…

Woot after hours (days ?) I finally made it.

But first, I must say that my problem was linking error with sublime. But when I tried to remove the tests and examples of sublime, the build process stopped at the same linking error as this ticket.

So, I was successful after installing macports clang-3.1 After an include file not found, I changed a line in :


I changed the line :

#elif defined GXX_LT_4_3

for :

#elif defined GXX_LT_4_3 || __APPLE__

and it worked.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 5 years ago by gregory.verret@…

oops Forgot, I used

sudo port install kdevplatform configure.compiler=macports-clang

comment:6 in reply to: ↑ 5 Changed 5 years ago by blixa@…

worked for me with apple's clang. thanks.

Changed 5 years ago by blixa@…

Changed 5 years ago by blixa@…

comment:7 Changed 5 years ago by NicosPavlov

  • Resolution set to fixed
  • Status changed from new to closed

This issue should be fixed with commit r94069 following ticket #34545.

Note: See TracTickets for help on using tickets.