Opened 9 years ago

Closed 9 years ago

#34170 closed defect (duplicate)

amarok: dyld: Symbol not found: __ZN6Amarok20qt_mac_set_dock_menuEP5QMenu

Reported by: steev@… Owned by: illogic-al@…
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc:
Port: amarok

Description (last modified by ryandesign (Ryan Schmidt))

Hello, I hope someone can help.

I finally managed to get Amarok in to install but now I can't get it to run.

The first time I tried it popped up with a splash screen saying about some configuration settings that needed to be made, but I didn't take note of what they were as I had to dash out. On the next start it didn't pop up with these changes and fails to start, generating a crash report.

If I try and run it from the command line I get the following.

abellio:LaunchAgents steev$ /Applications/MacPorts/KDE4/Amarok.app/Contents/MacOS/Amarok
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work 
amarok(37358)/KSharedDataCache ensureFileAllocated: This system misses support for posix_fallocate() -- ensure this partition has room for at least 10547296 bytes. 
amarok(37358)/KSharedDataCache: Unable to find an appropriate lock to guard the shared cache.  This *should* be essentially impossible. :( 
amarok(37358)/KSharedDataCache: Unable to perform initial setup, this system probably does not really support process-shared pthreads or semaphores, even though it claims otherwise. 
amarok(37358)/KSharedDataCache: Unable to unmap shared memory segment 0x10cae8000 
Object::connect: No such signal Phonon::QT7::MediaObject::availableSubtitlesChanged()
Object::connect: No such signal Phonon::QT7::MediaObject::availableAudioChannelsChanged()
Object::connect: No such signal Phonon::QT7::MediaObject::titleChanged(int)
Object::connect: No such signal Phonon::QT7::MediaObject::availableTitlesChanged(int)
Object::connect: No such signal Phonon::QT7::MediaObject::chapterChanged(int)
Object::connect: No such signal Phonon::QT7::MediaObject::availableChaptersChanged(int)
Object::connect: No such signal Phonon::QT7::MediaObject::angleChanged(int)
Object::connect: No such signal Phonon::QT7::MediaObject::availableAnglesChanged(int)
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=&lang=en&method=user.getNeighbours&user=" )  
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=&lang=en&method=user.getFriends&user=" )  
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=&lang=en&method=user.getTopTags&user=" )  
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=&lang=en&method=user.getTopArtists&user=" )  
amarok(37358)/KSharedDataCache ensureFileAllocated: This system misses support for posix_fallocate() -- ensure this partition has room for at least 10547296 bytes. 
amarok(37358)/KSharedDataCache: Unable to find an appropriate lock to guard the shared cache.  This *should* be essentially impossible. :( 
amarok(37358)/KSharedDataCache: Unable to perform initial setup, this system probably does not really support process-shared pthreads or semaphores, even though it claims otherwise. 
amarok(37358)/KSharedDataCache: Unable to unmap shared memory segment 0x112665000 
amarok(37358)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(37358)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(37358)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(37358)/KSharedDataCache ensureFileAllocated: This system misses support for posix_fallocate() -- ensure this partition has room for at least 1054816 bytes. 
amarok(37358)/KSharedDataCache: Unable to find an appropriate lock to guard the shared cache.  This *should* be essentially impossible. :( 
amarok(37358)/KSharedDataCache: Unable to perform initial setup, this system probably does not really support process-shared pthreads or semaphores, even though it claims otherwise. 
amarok(37358)/KSharedDataCache: Unable to unmap shared memory segment 0x11268c000 
QWidget::insertAction: Attempt to insert null action
amarok(37358)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
QSystemTrayIcon::setVisible: No Icon set
dyld: lazy symbol binding failed: Symbol not found: __ZN6Amarok20qt_mac_set_dock_menuEP5QMenu
  Referenced from: /opt/local/lib/libamaroklib.1.dylib
  Expected in: flat namespace

dyld: Symbol not found: __ZN6Amarok20qt_mac_set_dock_menuEP5QMenu
  Referenced from: /opt/local/lib/libamaroklib.1.dylib
  Expected in: flat namespace

Trace/BPT trap: 5

Any ideas as to how I can fix this? I have tried reinstalling it and selfupdating macports, I have also deleted the Amarok folder under

/Users/steev/Library/Preferences/KDE/share/apps/amarok with the hope it would prompt for the config again like it did the first time, but it just recreates that folder and then crashes.

Any help would be appreciated.

Thanks in advance.

Steev.

Change History (2)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: steev@… removed
Description: modified (diff)
Keywords: Amarok Crash removed
Owner: changed from macports-tickets@… to illogic-al@…
Port: amarok added; Amarok removed
Summary: Amarok won't runamarok: dyld: Symbol not found: __ZN6Amarok20qt_mac_set_dock_menuEP5QMenu

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #33099.

Note: See TracTickets for help on using tickets.