Opened 7 years ago

Closed 7 years ago

#34526 closed update (fixed)

p5-fusioninventory-agent @2.1.7 Update to 2.1.14

Reported by: mathieu.sim@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc:
Port: p5-fusioninventory-agent

Description

The version in MacPorts is quite old and misses several bugfixes regarding OS X compatibility. (Mostly 2.1.9 and the last 2.1.14 according to changelog)

Although 2.2 branch is out I first propose to properly update to the latest 2.1 branch release which is still considered maintained and stable for daily use. Please consider the attached patch.

This was tested under 10.7.4 with Xcode 4.3.2 and default compiler settings.

Attachments (3)

p5-fusioninventory-agent.2.1.7to2.1.14.patch (1.8 KB) - added by mathieu.sim@… 7 years ago.
Bump FusionInventory Agent from 2.1.7 to 2.1.14
p5-fusioninventory-agent.2.1.7to2.1.14-fixed1.patch (1.3 KB) - added by mathieu.sim@… 7 years ago.
Update FusionInventory 2.1.7 to 2.1.14 (correct-wise patch)
p5-fusioninventory-agent.2.1.7to2.1.14-fix2.patch (1.4 KB) - added by mathieu.sim@… 7 years ago.
Fix typo in description and updates it (as the agent will drop OCSng support soon)

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by mathieu.sim@…

Bump FusionInventory Agent from 2.1.7 to 2.1.14

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Keywords: fusioninventory removed
Version: 2.1.1

Patch looks reversed.

comment:2 Changed 7 years ago by mathieu.sim@…

You're absolutely correct - my joy of as a beginner was to great that my port worked so I didn't check my own diff.

I'll upload a fixed diff with the additional improvements:

  • Re-added the revision, it's zero, but present (instead of removing it)
  • FIxes dependencies so we get sub-ports for each perl version (p5.8-fusioninventory-agnet, p5.10-fusioninventory-agent etc.)
    • My very own fault, makes the new patch smaller :)
  • Fixes typo in the port description.

Changed 7 years ago by mathieu.sim@…

Update FusionInventory 2.1.7 to 2.1.14 (correct-wise patch)

comment:3 Changed 7 years ago by mf2k (Frank Schima)

This still doesn't look right. The long description looks reversed. Also no changes to the dependencies are in the patch.

comment:4 Changed 7 years ago by mathieu.sim@…

The description has a typo, agreed but:

  • OCSInventory is called OCSInventory-ng since for couple of years already
  • "FusionInventory for GLPI" is a plugin for GLPI replacing OCSInventory-ng as server side for those who want to. (2.2.x+ series will soon even drop support for OCSInventory-ng)

For the dependencies: The first initial patch touched a whole more lot which was wrong and would have messed up sub-ports, the new patch doesn't touch that anymore.

I'll fix the typos for the description tomorrow.

Changed 7 years ago by mathieu.sim@…

Fix typo in description and updates it (as the agent will drop OCSng support soon)

comment:5 Changed 7 years ago by ryandesign (Ryan Schmidt)

Keywords: haspatch added
Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

comment:6 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

Thanks. Committed with a few changes in r95420.

2.1.14 seems to no longer be available from the cpan mirror network, so I had to add backpan to the perl/cpan fetch group first in r95419.

Note: See TracTickets for help on using tickets.