Opened 15 years ago

Closed 15 years ago

#3454 closed defect (fixed)

UPDATE: py-game on 10.4

Reported by: benwill@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

The current py-game portfile doesn't seem to install the font, mixer and sndarray modules (others?) even though smpeg, libsdl_mixer are present.


[ben@assam-tol examples] $ port info py-game py-game 1.6.2, python/py-game http://www.pygame.org ...


[ben@assam-tol examples] $ pythonw Python 2.4.1 (#1, Jun 11 2005, 16:02:55) [GCC 4.0.0 20041026 (Apple Computer, Inc. build 4061)] on darwin Type "help", "copyright", "credits" or "license" for more information.

import pygame pygame.font

main__:1: RuntimeWarning: use font: No module named font Traceback (most recent call last):

File "<stdin>", line 1, in ? File "/opt/local/lib/python2.4/site-packages/pygame/init.py", line 41, in

getattr

raise NotImplementedError, MissingPygameModule

NotImplementedError: font module not available

pygame.sndarray

main__:1: RuntimeWarning: use sndarray: No module named sndarray Traceback (most recent call last):

File "<stdin>", line 1, in ? File "/opt/local/lib/python2.4/site-packages/pygame/init.py", line 41, in

getattr

raise NotImplementedError, MissingPygameModule

NotImplementedError: sndarray module not available

Change History (8)

comment:1 Changed 15 years ago by benwill@…

Also the movie module is not installed

(In reply to comment #0)

The current py-game portfile doesn't seem to install the font, mixer and sndarray modules (others?) even though smpeg, libsdl_mixer are present.


[ben@assam-tol examples] $ port info py-game py-game 1.6.2, python/py-game http://www.pygame.org ...


[ben@assam-tol examples] $ pythonw Python 2.4.1 (#1, Jun 11 2005, 16:02:55) [GCC 4.0.0 20041026 (Apple Computer, Inc. build 4061)] on darwin Type "help", "copyright", "credits" or "license" for more information.

import pygame pygame.font

main__:1: RuntimeWarning: use font: No module named font Traceback (most recent call last):

File "<stdin>", line 1, in ? File "/opt/local/lib/python2.4/site-packages/pygame/init.py", line 41, in

getattr

raise NotImplementedError, MissingPygameModule

NotImplementedError: font module not available

pygame.sndarray

main__:1: RuntimeWarning: use sndarray: No module named sndarray Traceback (most recent call last):

File "<stdin>", line 1, in ? File "/opt/local/lib/python2.4/site-packages/pygame/init.py", line 41, in

getattr

raise NotImplementedError, MissingPygameModule

NotImplementedError: sndarray module not available

comment:2 Changed 15 years ago by benwill@…

* Bug 3453 has been marked as a duplicate of this bug. *

comment:3 Changed 15 years ago by jmpp@…

Owner: changed from darwinports-bugs@… to mww@…

comment:4 Changed 15 years ago by benwill@…

Looks like this is Tiger-related: py-game expects libsdl_ttf, libsdl_image, libsdl_mixer and libsmpeg frameworks to be installed in /Library/Frameworks.

Portfiles for mixer, image, ttf only install the frameworks on platform 'darwin 7'. Oddly, smpeg doesn't seem to do it on any platform.

comment:5 Changed 15 years ago by benwill@…

OK: The libsdl_image, libsdl_mixer, libsdl_ttf problems are solved (on 10.4) by patches I submitted in bugs 3469, 3470 and 3471 respectively. Once those libraries install their frameworks correctly, py-game detects them fine.

I dunno what to do about smpeg though.

comment:6 Changed 15 years ago by benwill@…

The patch below is against the current py-game portfile: # $Id: Portfile,v 1.5 2005/04/21 15:58:11 jberry Exp $

It enables py-game to pick up the smpeg library correctly on 10.4. So, between this patch and those in bugs 3469, 3470 and 3471, py-game builds correctly on Tiger.

Can someone review/commit this stuff?

</end monologue>


31a32,42

platform darwin 8 { post-extract {

reinplace "s|FrameworkDependency('SMPEG|Dependency('SMPEG|g" \

${worksrcpath}/config_darwin.py

reinplace "s|libdirs =
\[|libdirs =
\['${prefix}/lib\'|g" \

${worksrcpath}/config_darwin.py

reinplace "s|incdirs =
\[|incdirs =
\['${prefix}/include/smpeg'|g" \

${worksrcpath}/config_darwin.py

} }

comment:7 Changed 15 years ago by benwill@…

Summary: py-game does not install font, mixer, sndarray modulesUPDATE: py-game on 10.4

comment:8 Changed 15 years ago by mww@…

Resolution: fixed
Status: newclosed

thanks a lot - fixed;

Note: See TracTickets for help on using tickets.