Opened 7 years ago

Closed 7 years ago

#34644 closed defect (fixed)

ports using phpize fail to install under xcode 4.3 because autoconf is not found

Reported by: dell@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.1.1
Keywords: phpize, autoconf Cc: jyrkiwahlstedt
Port: php

Description

Ports that use phpize (PHP extensions) fail to install under when using Xcode 4.3 because they require autoconf. Autotool are no longer bundled with Xcode 4.3.

https://discussions.apple.com/thread/3745105

Specifically, I tried to install the ports php5-mysql and php5-sqlite. Both failed to install:

Error: org.macports.configure for port php5-mysql returned: command execution failed
Please see the log file for port php5-mysql for details:

And the log reported the following error from phpize:

Cannot find autoconf. Please check your autoconf installation and the
$PHP_AUTOCONF environment variable. Then, rerun this script.

I was able to get them to install by installing the autoconf port first.

The autoconf port should be declared as a dependency under Xcode 4.3 for any ports that require it.

Change History (3)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: jwa@… added
Owner: changed from macports-tickets@… to ryandesign@…
Port: php added
Status: newassigned

Thanks for letting me know! I haven't upgraded to Lion or Xcode 4 yet so I was unaware. I'll make this change in the php and php5extension portgroups.

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Fixed php5extension portgroup and ports using it in r93612. The php portgroup and ports using it remains to be fixed.

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

Fixed php portgroup and ports using it in r93622.

Note: See TracTickets for help on using tickets.