Opened 7 years ago

Closed 7 years ago

#34855 closed update (fixed)

Update nmh port for 1.5 release

Reported by: kenh@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: maintainer Cc:
Port: nmh

Description

I've attached a Portfile for the new release of nmh (1.5).

One note: the previous nmh port (1.4) linked against the MacPorts version of cyrus-sasl2. I don't know if I specifically tested that back when the 1.4 version went in, but I tested that this time and I discovered that it does NOT work with Kerberos (the cyrus-sasl port doesn't work with the credential cache used by MacOS X).

I've been linking against the MacOS X-supplied Cyrus SASL libraries forever, and there have been no problems with it. So this Portfile does not have port:cyrus-sasl2 as a dependency. I kept in the dependency for openssl because that works fine.

Attachments (2)

Portfile (1.4 KB) - added by kenh@… 7 years ago.
Portfile for nmh 1.5
portfile-patch (1.6 KB) - added by kenh@… 7 years ago.
Patch for Portfile for nmh 1.5

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by kenh@…

Attachment: Portfile added

Portfile for nmh 1.5

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

We would prefer to receive a unified diff instead of a complete new portfile; this lets us see what changes you are proposing.

You can't just remove the cyrus-sasl2 dependency, because nmh will still link with it if cyrus-sasl2 is already installed. Either leave the cyrus-sasl2 dependency in the port, or ensure that it will not use cyrus-sasl2 even if it is already present.

comment:2 in reply to:  1 Changed 7 years ago by kenh@…

I'm trying to see how that would work, not linking against an installed cyrus-sasl2 ... the only way is to clear out configure.ldflags? Is there another way I'm missing? Or should I just mark nmh as conflicting against cyrus-sasl2?

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

Marking the port as conflicting would not be correct. The conflicts keyword is for ports that install the same files. nmh and cyrus-sasl2 do not install the same files.

For most programs, you would just provide a flag to the ./configure script. You're providing the --with-cyrus-sasl configure arg, which means "please use cyrus-sasl2". To tell it to not use cyrus-sasl2, you would presumably use the option "--without-cyrus-sasl". I guess the problem is that you want to use the system version of cyrus-sasl instead of the MacPorts version.

You're right that clearing the configure.ldflags would probably work. You might also have to clear compiler.library_path. But would these changes also affect the tls variant? If so, you would need to fix the tls variant so that it still uses the MacPorts openssl port.

Changed 7 years ago by kenh@…

Attachment: portfile-patch added

Patch for Portfile for nmh 1.5

comment:4 Changed 7 years ago by kenh@…

Ok, I've attached a patch for the current Portfile which I believe addresses all of the issues you brought up.

comment:5 Changed 7 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed
Version: 2.1.1
Note: See TracTickets for help on using tickets.