Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#34898 closed defect (invalid)

Could not continue interrupted upgrade (Mac OS 10.6)

Reported by: alexey.muranov@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 2.1.1
Keywords: Cc:
Port:

Description

I am lazy to try to reproduce this bug, but this is what happened:

i interrupted "port upgrade outdated" with <Control-C>, and then could not continue because the "port" was saying, that no packages matched "outdated". I cleaned all installed ports, tried to upgrade, and it started upgrading, but i had the impression it was trying to install the default variants, and not the custom one that was installed before (i noticed this for octave-devel).

At least this is what i remember, this is somewhat time-consuming to reproduce.

Change History (3)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed

This is a fairly vague description of events with no clear indication of any particular bug in MacPorts. I suggest you ask on the macports-users mailing list if you need help getting your MacPorts installation working correctly again.

comment:2 Changed 8 years ago by alexey.muranov@…

Ok, thanks. I will report again if i reproduce it. The problem was that i could not continue upgrade after <Control-C>, i do not know if this is an expected behavior.

comment:3 Changed 8 years ago by alexey.muranov@…

Here is what i got today when doing "upgrade outdated":

---> Computing dependencies for octave-devel ---> Cleaning octave-devel ---> Scanning binaries for linking errors: 100.0% ---> Found 18 broken file(s), matching files to ports ---> Found 2 broken port(s), determining rebuild order ---> Rebuilding in order

gcc45 @4.5.3 octave-devel @3.4.3 +accelerate+gcc44

I think this is the first upgrade of octave-devel since the problem that i described happened.

Note: See TracTickets for help on using tickets.