Opened 9 years ago

Closed 9 years ago

#34992 closed defect (worksforme)

selfupdate fails: trying to use another username as argument

Reported by: spam4scott@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 2.1.1
Keywords: selfupdate Cc:
Port:

Description (last modified by ryandesign (Ryan Schmidt))

Hi. The resolved tickets I've found related to this all seem to have been resolved by the user updating their version of XCode, but I have the latest XCode (4.3.3) and OS 10.7.4.

% sudo port -v selfupdate

(output removed by admin; see attached log file instead)

Now 'andrewlove' is a username on my system, which is unused. No idea why it's become an argument that MacPorts wants.

Tried to fix this by deleting his account and user directory. No effect.

Also tried downloading the latest MacPorts .dmg and installing overtop of my existing installation. No effect.

Can anyone recommend a fix? I can't install new ports because it says my tables are out of date and I need to run selfupdate...

Thanks.

Attachments (1)

port_log.txt (21.2 KB) - added by spam4scott@… 9 years ago.
Port log output (with proper carriage returns)

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by spam4scott@…

Attachment: port_log.txt added

Port log output (with proper carriage returns)

comment:1 Changed 9 years ago by spam4scott@…

After viewing ticket #27353 , I noticed my whole /opt tree was owned by user 'andrewlove'.

Executed a 'sudo chown -R root /opt'

Now selfupdate works fine. :-)

/worksforme

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Component: portsbase
Description: modified (diff)
Resolution: worksforme
Status: newclosed

Looking through the log searching for "andrewlove", I see various lines:

Installing new MacPorts release in /opt/local as andrewlove:1000; permissions 0755; Tcl-Package in /Library/Tcl
checking for install user... andrewlove
checking for install group... 1000
checking for macports user... macports
checking for Applications installation directory... ~andrewlove/Applications/MacPorts
checking for Frameworks installation directory... /opt/local/Library/Frameworks

And then of course the ultimate failure:

===> making install in doc
/usr/bin/install -c -d -o andrewlove -g 1000 -m 755 /opt/local
install: andrewlove: Invalid argument
make[1]: *** [install] Error 67
make: *** [install] Error 1

If it was not your intention for applications to get installed in ~andrewlove/Applications/MacPorts, or for user andrewlove (which the error message "Invalid argument" seems to be telling you is not a valid username on your system) and group 1000 to own the MacPorts installation, you should consult your macports.conf file; perhaps erroneous settings have been entered there.

Note: See TracTickets for help on using tickets.