Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#35145 closed defect (fixed)

firefox-x11 @7.0.1_2: error: non-constant-expression cannot be narrowed from type 'int' to 'SInt8' (aka 'signed char') in initializer list [-Wc++11-narrowing]

Reported by: cubranic@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.1
Keywords: Cc: cooljeanius (Eric Gallager), ryandesign (Ryan Schmidt)
Port: firefox-x11

Description

There is a build error with OS X 10.7.4, Xcode 4.3.3, Clang 3.1:

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org
_release_tarballs_ports_www_firefox-x11/firefox-x11/work/mozilla-release/ipc/chr
omium/src/base/process_util_mac.mm:189:53: error: non-constant-expression cannot
 be narrowed from type 'uid_t' (aka 'unsigned int') to 'int' in initializer list
 [-Wc++11-narrowing]
  int mib[] = { CTL_KERN, KERN_PROC, KERN_PROC_UID, geteuid() };
                                                    ^~~~~~~~~

Attachments (2)

firefox-x11.log (3.3 MB) - added by cubranic@… 7 years ago.
firefox-x11-llvm-gcc-4.2.log (3.7 MB) - added by cubranic@… 7 years ago.

Change History (14)

Changed 7 years ago by cubranic@…

Attachment: firefox-x11.log added

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Changed 7 years ago by cubranic@…

comment:2 Changed 7 years ago by cubranic@…

Building with llvm-gcc-4.2 also fails: see attached log.

comment:3 Changed 7 years ago by cubranic@…

I succeeded with Apple's gcc-4.2 (from http://r.research.att.com/tools, not the apple-gcc-42 port, but it's the essentially the same compiler).

Compiler version info: i686-apple-darwin11-gcc-4.2.1 (GCC) 4.2.1 (Apple Inc. build 5666) (dot 3)

comment:4 Changed 7 years ago by amake (Aaron Madlon-Kay)

I can confirm that building firefox-x11 7.0.1 fails on OS X 10.8.1 (Xcode 4.4) with the default compiler and with llvm-gcc-4.2, but succeeds with apple-gcc-4.2 (as provided by the apple-gcc-42 port).

Last edited 7 years ago by amake (Aaron Madlon-Kay) (previous) (diff)

comment:5 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: cdcooke@… added
Summary: firefox-x11 @7.0.1: build errorfirefox-x11 @7.0.1_2: error: non-constant-expression cannot be narrowed from type 'int' to 'SInt8' (aka 'signed char') in initializer list [-Wc++11-narrowing]

Has duplicate #37806.

comment:6 Changed 6 years ago by cooljeanius (Eric Gallager)

Besides this, the firefox-x11 port probably needs to be updated, too:

    gl00b05044:~ root# port livecheck firefox-x11
    firefox-x11 seems to have been updated (port version: 7.0.1, new version: 489)

Maybe after being updated this error will disappear?

comment:7 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:8 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: fixed
Status: newclosed

The previous maintainer dropped maintenance of the port because updating it was such a pain, so I'm certainly not going to try. Others are welcome to.

Forced the use of apple-gcc-4.2 in r102099.

comment:9 in reply to:  8 Changed 6 years ago by ryandesign (Ryan Schmidt)

Replying to ryandesign@…:

The previous maintainer dropped maintenance of the port because updating it was such a pain, so I'm certainly not going to try. Others are welcome to.

....which is #33068

comment:10 Changed 6 years ago by cdcooke@…

Cc: cdcooke@… removed

Cc Me!

comment:11 Changed 6 years ago by cdcooke@…

Cc: cdcooke@… added

Cc Me!

comment:12 Changed 6 years ago by cdcooke@…

Cc: cdcooke@… removed

Cc Me!

Note: See TracTickets for help on using tickets.