Opened 8 years ago

Closed 8 years ago

#35156 closed defect (duplicate)

netpbm build failure on Mountain Lion

Reported by: nicolas.jessel@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.1
Keywords: mountainlion Cc: ryandesign (Ryan Schmidt)
Port: netpbm

Description

I would like to install netpbm-10.59 on Mountain Lion and the build is failure. I had already macports installed on Lion and netpbm was in 10.46 version.

I do "sudo port -fuc upgrade outdated" and all ports was upgraded but not netpbm.

I attached the trace of the install.

Thanks in advance for your help.

Attachments (1)

main.log (649.8 KB) - added by nicolas.jessel@… 8 years ago.
log after clean port netpbm

Download all attachments as: .zip

Change History (8)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Keywords: mountainlion added; depbm failure mountain lion removed
Port: netpbm added; depbm removed
Priority: HighNormal

The log you attached is incomplete. To generate a complete one, "sudo port clean netpbm" and try again.

You should report the problem to the developers of netpbm so they can fix it.

Mountain Lion is not out yet publicly, so we cannot help you with it yet.

Changed 8 years ago by nicolas.jessel@…

Attachment: main.log added

log after clean port netpbm

comment:2 Changed 8 years ago by nicolas.jessel@…

I have sent an email to bryanh@… and I hope he will find a solution.

I have uploaded the log after cleaning netpbm port with "sudo port clean netpbm".

Thanks for your help.

comment:3 Changed 8 years ago by ryandesign (Ryan Schmidt)

One place you could start looking for a workaround is using a different compiler.

comment:4 in reply to:  3 Changed 8 years ago by nicolas.jessel@…

Replying to ryandesign@…:

One place you could start looking for a workaround is using a different compiler.

This solution works fine, thanks.

comment:5 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: worksforme
Status: newclosed

Unable to reproduce on Mountain Lion 10.8.0 with Xcode 4.4; builds fine for me with the default compiler (clang). Perhaps this was a problem in the pre-release versions of Mountain Lion and/or Xcode that you were using.

comment:6 Changed 8 years ago by neverpanic (Clemens Lang)

Resolution: worksforme
Status: closedreopened

This is because Jeremy fixed it in r95870. This is a duplicate of #35310.

comment:7 Changed 8 years ago by neverpanic (Clemens Lang)

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.