Opened 9 years ago

Closed 9 years ago

#35238 closed defect (duplicate)

shogun: undefined symbols

Reported by: trandu@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.1
Keywords: Cc: jameskyle@…
Port: shogun

Description (last modified by ryandesign (Ryan Schmidt))

bash-3.2$ sudo port install shogun
--->  Computing dependencies for shogun
--->  Fetching archive for shogun
--->  Attempting to fetch shogun-0.9.3_0+gcc45.darwin_9.i386.tbz2 from http://packages.macports.org/shogun
--->  Fetching distfiles for shogun
--->  Verifying checksum(s) for shogun
--->  Extracting shogun
--->  Applying patches to shogun
--->  Configuring shogun
--->  Building shogun
Error: org.macports.build for port shogun returned: command execution failed
Please see the log file for port shogun for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_shogun/shogun/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port shogun failed

Attachments (1)

main.log (336.8 KB) - added by trandu@… 9 years ago.

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by trandu@…

Attachment: main.log added

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: jameskyle@… added
Description: modified (diff)
Port: shogun added
Resolution: duplicate
Status: newclosed
Summary: Error when building shogunshogun: undefined symbols

Please remember to use WikiFormatting, to fill in the Port field, and to Cc the maintainer of that port.

The errors in the log begin with:

:info:build Undefined symbols for architecture i386:
:info:build   "_drot_", referenced from:
:info:build       _dbdsqr_ in liblapack.a(dbdsqr.o)
:info:build   "_dswap_", referenced from:
:info:build       _dbdsqr_ in liblapack.a(dbdsqr.o)
:info:build       _dsteqr_ in liblapack.a(dsteqr.o)
:info:build      (maybe you meant: _ATL_dswap_xp0yp0aXbX)
:info:build   "_dgemm_", referenced from:
:info:build       _dgesvd_ in liblapack.a(dgesvd.o)
:info:build       _dgebrd_ in liblapack.a(dgebrd.o)
:info:build   "__gfortran_concat_string", referenced from:
:info:build       _dgesvd_ in liblapack.a(dgesvd.o)
:info:build       _dormbr_ in liblapack.a(dormbr.o)
:info:build       _dormqr_ in liblapack.a(dormqr.o)
:info:build       _dormlq_ in liblapack.a(dormlq.o)

So this is a duplicate of #34990.

Note: See TracTickets for help on using tickets.