Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#35242 closed defect (worksforme)

ecl: missing dependencies on libffi and gmp

Reported by: rpgoldman@… Owned by: easye
Priority: Normal Milestone:
Component: ports Version: 2.1.1
Keywords: Cc: waqar@…, geekosaur
Port: ecl

Description

Here's what I see in the output from an ECL session (this from trying to run the regression tests for ASDF):

LOAD: Could not load file
#P"/Users/rpg/lisp/asdf/tmp/fasls/ecl-12.2.1-unknown-macosx-x86/test/file3.fas"
(Error:
"dlopen(/Users/rpg/lisp/asdf/tmp/fasls/ecl-12.2.1-unknown-macosx-x86/test/file3.fas,
10): Library not loaded: /opt/local/lib/libffi.5.dylib

This makes sense, because I have libffi.6.dylib, not .5.

Should this be reflected in the dependencies of ecl? Because if I do port deps ecl, I get

ecl @12.2.1_0 has no dependencies.

Change History (4)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to easieste@…
Summary: ecl @12.2.1 tries to load old version of libffi.dylibecl: missing dependencies on libffi and gmp
$ cd $(port work ecl)/*/build
$ otool -L ecl_min
ecl_min:
	/opt/local/lib/libgmp.10.dylib (compatibility version 11.0.0, current version 11.4.0)
	/opt/local/lib/libffi.6.dylib (compatibility version 7.0.0, current version 7.0.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11)

comment:2 Changed 9 years ago by jmroot (Joshua Root)

Cc: waqar@… added

comment:3 Changed 9 years ago by easye

Resolution: worksforme
Status: newclosed

After upgrading to ecl-12.7.1 in https://trac.macports.org/changeset/97575, I don't see that either ecl_min or the ECL fas links in libgmp or libffi.

To test, I deactivated both libgmp and libffi, built ecl, then successfully ran the ASDF tests from the git master.

Closing this issue, so please test with newer version of port to see you still see failure to properly include dependencies.

comment:4 Changed 9 years ago by rpgoldman@…

Looks good to me, too. Thanks!

Note: See TracTickets for help on using tickets.