Opened 9 years ago

Closed 9 years ago

#35243 closed defect (fixed)

mlt: transition_composite.c compile error

Reported by: mikyboum@… Owned by: ddennedy (Dan Dennedy)
Priority: Normal Milestone:
Component: ports Version: 2.1.1
Keywords: haspatch Cc:
Port: mlt

Description (last modified by ryandesign (Ryan Schmidt))

Hi, I have a problem when i use the command "sudo port install mlt" the file "transition_composite.c" doesn't compile and the error is :

/usr/bin/llvm-gcc-4.2 -O2 -I/opt/local/include -I/opt/local/include -DARCH_X86_64 -Wall -DPIC   -O2 -pipe -fno-tree-dominator-opts -fno-tree-pre -DUSE_MMX -DUSE_SSE -DUSE_SSE2 -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fPIC -D__DARWIN__ -I/opt/local/include/SDL -D_GNU_SOURCE=1 -D_THREAD_SAFE -DARCH_X86_64 -Wall -DPIC   -O2 -pipe -fno-tree-dominator-opts -fno-tree-pre -DUSE_MMX -DUSE_SSE -DUSE_SSE2 -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fPIC -D__DARWIN__ -I/opt/local/include/SDL -D_GNU_SOURCE=1 -D_THREAD_SAFE -I../.. -DARCH_X86_64 -Wall -DPIC   -O2 -pipe -fno-tree-dominator-opts -fno-tree-pre -DUSE_MMX -DUSE_SSE -DUSE_SSE2 -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fPIC -D__DARWIN__ -I/opt/local/include/SDL -D_GNU_SOURCE=1 -D_THREAD_SAFE   -c -o transition_composite.o transition_composite.c
{standard input}:186:FATAL:Symbol loop_start already defined.
make[2]: *** [transition_composite.o] Error 2

Please help me.

Best regards

Attachments (6)

main.log (19.0 KB) - added by jimrandomh@… 9 years ago.
main.2.log (181.2 KB) - added by jimrandomh@… 9 years ago.
Using clang instead of llvm
main.3.log (79.3 KB) - added by mikyboum@… 9 years ago.
mlt-Portfile-35243.diff (431 bytes) - added by ddennedy (Dan Dennedy) 9 years ago.
patch-src-modules-core-sse2.diff (3.1 KB) - added by ddennedy (Dan Dennedy) 9 years ago.
patch-src-modules-core-sse2.2.diff (2.9 KB) - added by ddennedy (Dan Dennedy) 9 years ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to dan@…
Port: mlt added
Priority: HighNormal
Summary: transition_composite.c compile errormlt: transition_composite.c compile error

It might help Dan diagnose the problem if you attached the main.log file.

It might be a compiler-specific problem, in which case you might be able to work around it by using a different compiler.

Changed 9 years ago by jimrandomh@…

Attachment: main.log added

Changed 9 years ago by jimrandomh@…

Attachment: main.2.log added

Using clang instead of llvm

comment:2 Changed 9 years ago by jimrandomh@…

I'm also affected, and reproduced the problem with two different compilers. Clang gave a more informative error message:

:info:build /usr/bin/clang -O2 -I/opt/local/include -I/opt/local/include -DARCH_X86_64 -Wall -DPIC -O2 -pipe -fno-tree-dominator-opts -fno-tree-pre -DUSE_MMX -DUSE_SSE -DUSE_SSE2 -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fPIC -DDARWIN -I/opt/local/include/SDL -D_GNU_SOURCE=1 -D_THREAD_SAFE -DARCH_X86_64 -Wall -DPIC -O2 -pipe -fno-tree-dominator-opts -fno-tree-pre -DUSE_MMX -DUSE_SSE -DUSE_SSE2 -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fPIC -DDARWIN -I/opt/local/include/SDL -D_GNU_SOURCE=1 -D_THREAD_SAFE -I../.. -DARCH_X86_64 -Wall -DPIC -O2 -pipe -fno-tree-dominator-opts -fno-tree-pre -DUSE_MMX -DUSE_SSE -DUSE_SSE2 -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fPIC -DDARWIN -I/opt/local/include/SDL -D_GNU_SOURCE=1 -D_THREAD_SAFE -c -o transition_composite.o transition_composite.c:info:build clang: warning: argument unused during compilation: '-O2' :info:build clang: warning: argument unused during compilation: '-O2' :info:build clang: warning: argument unused during compilation: '-fno-tree-dominator-opts':info:build clang: warning: argument unused during compilation: '-fno-tree-pre' :info:build clang: warning: argument unused during compilation: '-O2' :info:build clang: warning: argument unused during compilation: '-fno-tree-dominator-opts' :info:build clang: warning: argument unused during compilation: '-fno-tree-pre':info:build clang: warning: argument unused during compilation: '-fno-tree-dominator-opts' :info:build clang: warning: argument unused during compilation: '-fno-tree-pre' :info:build In file included from transition_composite.c:369: :info:build ./composite_line_yuv_sse2_simple.c:10:9: error: invalid symbol redefinition :info:build "pxor %%xmm0, %%xmm0 \n\t" /* clear zero register */ :info:build :info:build <inline asm>:7:2: note: instantiated into assembly here :info:build loop_start: :info:build

comment:3 Changed 9 years ago by jimrandomh@…

D'oh, fuck WikiFormatting. It's readable in main.2.log.

comment:4 Changed 9 years ago by ddennedy (Dan Dennedy)

On my system, if I change -O2 to -O1 then the problem goes away, but I do like that change and want to figure out real reason.

comment:5 Changed 9 years ago by mikyboum@…

thank you for your comments. Can you help me because i can't use "port install mlt" ? it doesn't work ? i don't know where to change the file

Changed 9 years ago by mikyboum@…

Attachment: main.3.log added

comment:6 Changed 9 years ago by mikyboum@…

i attach my main.log. Please help me, my system is Macbook Pro Mac OS X v10.6.8.

Changed 9 years ago by ddennedy (Dan Dennedy)

Attachment: mlt-Portfile-35243.diff added

Changed 9 years ago by ddennedy (Dan Dennedy)

comment:7 Changed 9 years ago by ddennedy (Dan Dennedy)

I have attached the fixes. If you are observing this bug but do not have experience with local ports, then you can wait for the patches to be accepted or try to learn how to use local ports from the Guide.

comment:9 Changed 9 years ago by jimrandomh@…

I confirm that the patch fixes the problem for me.

comment:10 Changed 9 years ago by mikyboum@…

thank you very much it works.

Changed 9 years ago by ddennedy (Dan Dennedy)

comment:11 Changed 9 years ago by ddennedy (Dan Dennedy)

I just added a newer patch to because previous one created regression building on 32-bit.

comment:12 Changed 9 years ago by jmroot (Joshua Root)

Keywords: haspatch added

Do you want to commit this patch? Or just update to 0.8.2?

comment:13 Changed 9 years ago by ddennedy (Dan Dennedy)

Yesterday, I was using MacPorts and realized I had not updated my port to 0.8.2. I will do that now.

comment:14 Changed 9 years ago by ddennedy (Dan Dennedy)

see ticket #36154 for the port upgrade

comment:15 Changed 9 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.