Opened 9 years ago

Closed 9 years ago

#35246 closed defect (duplicate)

qt4-x11 doesn't compile for lion

Reported by: barto@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.1
Keywords: Cc:
Port: qt4-x11

Description (last modified by ryandesign (Ryan Schmidt))

All required packages are successfully down loaded and the patches are applied correctly. When compiling however it fails because:

:info:configure In file included from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_qt4-x11/qt4-x11/work/qt-x11-opensource-src-4.4.3/include/QtCore/qglobal.h:1:
:info:configure /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_qt4-x11/qt4-x11/work/qt-x11-opensource-src-4.4.3/include/QtCore/../../src/corelib/global/qglobal.h:290:6: error: #error "This version of Mac OS X is unsupported"
:info:configure #    error "This version of Mac OS X is unsupported"
:info:configure      ^
:info:configure 1 error generated.
:info:configure make: *** [project.o] Error 1

Change History (1)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: qt removed
Port: qt4-x11 added; qt removed
Resolution: duplicate
Status: newclosed
Summary: qt-x11 doesn't compile for lionqt4-x11 doesn't compile for lion

Duplicate of #20309.

Note: See TracTickets for help on using tickets.