Opened 17 years ago

Closed 17 years ago

Last modified 16 years ago

#354 closed defect (duplicate)

dependencies rebuilt unnecessarily

Reported by: ssen@… Owned by: kvv@…
Priority: Normal Milestone:
Component: base Version: 1.0
Keywords: Cc:
Port:

Description

port install foo will often rebuild dependencies unnecessarily if foo has a dense dependence tree. For example, if you have port A depending on B and C, and B depending on C, C will get rebuilt twice (!!!). For complicated things like qt3 and XFree86, rebuilding is not acceptable.

The attached test.tar.gz has 3 fake ports of this fashion. If you do "port install A": ---> Fetching A ---> Verifying checksum for A ---> Extracting A ---> Fetching B ---> Verifying checksum for B ---> Extracting B ---> Fetching C ---> Verifying checksum for C ---> Extracting C ---> Configuring C ---> Building C with target all ---> Installing C ---> Cleaning C ---> Configuring B ---> Building B with target all ---> Installing B ---> Cleaning B ---> Fetching C ---> Verifying checksum for C ---> Extracting C ---> Configuring C ---> Building C with target all ---> Installing C ---> Cleaning C ---> Configuring A ---> Building A with target all ---> Installing A

This is clearly not desirable

Attachments (1)

test.tar.gz (586 bytes) - added by ssen@… 17 years ago.
port A, B, C

Download all attachments as: .zip

Change History (2)

Changed 17 years ago by ssen@…

Attachment: test.tar.gz added

port A, B, C

comment:1 Changed 17 years ago by kevin@…

Resolution: duplicate
Status: newclosed

Committing some stuff tonight which should fix this. Tracking on original bug #333.

* This bug has been marked as a duplicate of 333 *

Note: See TracTickets for help on using tickets.