Opened 7 years ago

Closed 7 years ago

#35409 closed defect (fixed)

octave: fatal error: curl/types.h: No such file or directory

Reported by: bobm.dsp@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: mountainlion Cc: vic@…, mechgyver@…, lawrence.ong@…, onurdomanic@…, AlonzoQuixote@…, nils.hjelte@…, jmosorioguillen@…, bhadder@…, ahlid@…, waterson@…, MacPorts@…
Port: octave

Description (last modified by ryandesign (Ryan Schmidt))

When trying to install port octave on Mountain Lion I'm getting an error:

Error: org.macports.build for port octave returned: command execution failed

And finally:

Error: Processing of port octave failed

This is on Mountain Lion. I have tried the following, without success:

  1. Removed MacPorts completely
  2. Reinstalled MacPorts using 2.1.2 Mountain Lion package
  3. Confirmed Xcode command line tools have been installed
  4. sudo xcodebuild -license (this fixed some prior problems)
  5. sudo port clean octave and then attempted to reinstall
  6. Changed the server in sources.conf to “http://www.macports.org/files/ports.tar.gz [default]“ (this fixed other prior problems)

This all helped with problems getting dependencies built. But no luck yet with octave or octave-devel. I will attach the log file.

Attachments (5)

main.log (975.0 KB) - added by bobm.dsp@… 7 years ago.
main.log associated with octave build error
octave-devel main.log (1.0 MB) - added by bobm.dsp@… 7 years ago.
octave-devel main.log file
main.2.log (1.1 MB) - added by vic@… 7 years ago.
Portfile (5.3 KB) - added by kitchen.andy@… 7 years ago.
patch-src-DLD-FUNCTIONS-urlwrite.cc.diff (305 bytes) - added by kitchen.andy@… 7 years ago.

Change History (25)

Changed 7 years ago by bobm.dsp@…

Attachment: main.log added

main.log associated with octave build error

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: mountainlion added; octave mountain lion removed
Summary: Processing of port octave failed on Mountain Lionoctave: fatal error: curl/types.h: No such file or directory

The relevant error in the log seems to be:

fatal error: curl/types.h: No such file or directory

Try the port octave-devel instead; it's a newer version that might work better.

Changed 7 years ago by bobm.dsp@…

Attachment: octave-devel main.log added

octave-devel main.log file

comment:2 Changed 7 years ago by bobm.dsp@…

Thank you. I tried octave-devel and got an error as well. The main.log file is attached here.

I'd prefer to use octave-devel, but when I tried octave-devel on Lion I was unable to get it to recognize the functions from the octave-signal port. With the octave port, I was able to use the octave-signal functions.

Changed 7 years ago by vic@…

Attachment: main.2.log added

comment:3 Changed 7 years ago by vic@…

I cannot compile octave-devel on Mountain Lion. I have recompiled MacPorts from scratch and compiled all the dependencies for octave-devel, but octave-devel won't compile. I'm attaching the log of my (clean) installation attempt

comment:4 Changed 7 years ago by vic@…

Cc: vic@… added

Cc Me!

comment:5 Changed 7 years ago by vic@…

Cc: vic@… removed

Cc Me!

comment:6 Changed 7 years ago by vic@…

Cc: vic@… added

Cc Me!

comment:7 Changed 7 years ago by mechgyver@…

Cc: mechgyver@… added

Cc Me!

comment:8 Changed 7 years ago by lawrence.ong@…

Cc: lawrence.ong@… added

Cc Me!

comment:9 Changed 7 years ago by lawrence.ong@…

One solution is to remove the line

#include <curl/types.h>

in

/opt/local/var/macports/build/_Users_lolc_macports_svn.macports.org_trunk_dports_math_octave/octave/work/octave-3.2.4/src/DLD-FUNCTIONS/urlwrite.cc

This solution was documented at http://lists.gnu.org/archive/html/octave-bug-tracker/2011-07/msg00031.html.

comment:10 Changed 7 years ago by onurdomanic@…

Cc: onurdomanic@… added

Cc Me!

comment:11 Changed 7 years ago by AlonzoQuixote@…

Cc: AlonzoQuixote@… added

Cc Me!

comment:12 Changed 7 years ago by nils.hjelte@…

Cc: nils.hjelte@… added

Cc Me!

comment:13 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: jmosorioguillen@… added

Has duplicate #35527.

comment:14 Changed 7 years ago by bhadder@…

Cc: bhadder@… added

Cc Me!

comment:15 Changed 7 years ago by kitchen.andy@…

Attaching patch and Portfile to make octave compile with newer curl.

Changed 7 years ago by kitchen.andy@…

Attachment: Portfile added

Changed 7 years ago by kitchen.andy@…

comment:16 Changed 7 years ago by ahlid@…

Cc: ahlid@… added

Cc Me!

comment:17 Changed 7 years ago by waterson@…

Cc: waterson@… added

Cc Me!

comment:18 Changed 7 years ago by MacPorts@…

Cc: MacPorts@… added

Cc Me!

comment:19 Changed 7 years ago by MacPorts@…

The above advice did not work for me (my change in the source was ignored), but the following hack did work:

sudo touch /opt/local/include/curl/types.h

comment:20 Changed 7 years ago by NicosPavlov

Resolution: fixed
Status: newclosed

Patch committed in r97830.

Note: See TracTickets for help on using tickets.