Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#35451 closed defect (invalid)

New port installation whereas simple upgrade.

Reported by: devin.plompier@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: w3m

Description (last modified by ryandesign (Ryan Schmidt))

I switch to Mountain Lion. When I try do run an upgrade outdated, it want to install the port w3m whereas I never installed it ! I checked it with port installed.
And naturally, it doesn't works (see #35328).

Change History (4)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: devin.plompier@… removed
Description: modified (diff)
Resolution: invalid
Status: newclosed

If you did not have w3m installed before, but MacPorts is trying to install it now, then you are probably trying to upgrade a port that depends on w3m (babl, gegl, or emacs-w3m), or a port that depends on one of those, etc. Such a dependency might have been added or changed since you last installed these ports, which would explain why you did not have w3m installed before. Or, it may be a dependency that is only needed on Mountain Lion.

comment:2 Changed 7 years ago by devin.plompier@…

Ok. Thank you.
I'm just hoping that the problem in the building will be solved quickly, because i cannot overstep this port, and all the other are waiting.

comment:3 Changed 7 years ago by neverpanic (Clemens Lang)

This should be fixed, see #35080. Try running selfupdate, clean w3m and re-try. If it fails, please re-open #35080.

comment:4 Changed 7 years ago by devin.plompier@…

It works. Thanks.

Note: See TracTickets for help on using tickets.