Opened 9 years ago

Closed 7 years ago

#35532 closed defect (worksforme)

lftp random crash on 10.8 (Mountain Lion)

Reported by: jackh48@… Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: lftp

Description (last modified by ryandesign (Ryan Schmidt))

Cron job running lftp v4.3.5 upload scripts periodically crashes running job with:-

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

and variously Exception Codes:

EXC_I386_GPFLT
KERN_INVALID_ADDRESS at 0x00000000000000a5

Self -installed v4.3.8 does not exhibit this behaviour.

Consider update to upstream code.

Attachments (1)

Archive.zip (66.5 KB) - added by jackh48@… 9 years ago.
Running program Crash - lftp

Download all attachments as: .zip

Change History (11)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: lftp added

I've updated lftp to version 4.3.8 in r96228. Did that help?

Changed 9 years ago by jackh48@…

Attachment: Archive.zip added

Running program Crash - lftp

comment:2 Changed 9 years ago by jackh48@…

My self-installed from source, and the macports version appear to be linked against different libraries, Viz:-

/usr/local/bin/lftp --version shows:-

Libraries used: Readline 6.2, Expat 2.1.0, GnuTLS 2.12.19, libiconv 1.14, zlib 1.2.7

/opt/local/bin/lftp --version shows:-

Libraries used: Readline 6.2, Expat 2.1.0, OpenSSL 1.0.1c 10 May 2012, libiconv 1.14, zlib 1.2.7

I attach an archive of my running crash logs - the ones on 28/7 are old v4.3.5; the newer ones are v4.3.8. In the period in between I ran /usr/local/bin/lftp (every minute), without failure.

Actually, here is lsof for /usr/local/bin/lftp

bash-3.2$ lsof -p 41196
COMMAND   PID     USER   FD   TYPE DEVICE  SIZE/OFF      NODE NAME
lftp    41196 johnhall  cwd    DIR    1,1      3128 249682893 /usr/local/bin
lftp    41196 johnhall  txt    REG    1,1   1331300 252899621 /usr/local/bin/lftp
lftp    41196 johnhall  txt    REG    1,1    291868 249919774 /opt/local/lib/libexpat.1.dylib
lftp    41196 johnhall  txt    REG    1,1   1472692 250498302 /opt/local/lib/libgnutls.26.dylib
lftp    41196 johnhall  txt    REG    1,1    144704 250476649 /opt/local/lib/libtasn1.3.dylib
lftp    41196 johnhall  txt    REG    1,1   1053004 250473693 /opt/local/lib/libgcrypt.11.dylib
lftp    41196 johnhall  txt    REG    1,1     42204 250469523 /opt/local/lib/libgpg-error.0.dylib
lftp    41196 johnhall  txt    REG    1,1    165796 249991346 /opt/local/lib/libz.1.2.7.dylib
lftp    41196 johnhall  txt    REG    1,1    107612 249988105 /opt/local/lib/libintl.8.dylib
lftp    41196 johnhall  txt    REG    1,1   2116812 249929212 /opt/local/lib/libiconv.2.dylib
lftp    41196 johnhall  txt    REG    1,1    450064 250208228 /opt/local/lib/libreadline.6.2.dylib
lftp    41196 johnhall  txt    REG    1,1    580492 249944158 /opt/local/lib/libncurses.5.dylib
lftp    41196 johnhall  txt    REG    1,1    600576 249366287 /usr/lib/dyld
lftp    41196 johnhall  txt    REG    1,1 301068288 249682319 /private/var/db/dyld/dyld_shared_cache_x86_64
lftp    41196 johnhall    0u   CHR   16,0   0t52323       811 /dev/ttys000
lftp    41196 johnhall    1u   CHR   16,0   0t52323       811 /dev/ttys000
lftp    41196 johnhall    2u   CHR   16,0   0t52323       811 /dev/ttys000
lftp    41196 johnhall    3r   DIR    1,1      3128 249682893 /usr/local/bin
bash-3.2$ 

and again for /opt/local/bin/lftp

bash-3.2$ lsof -p 41294
COMMAND   PID     USER   FD   TYPE DEVICE  SIZE/OFF      NODE NAME
lftp    41294 johnhall  cwd    DIR    1,1      3128 249682893 /usr/local/bin
lftp    41294 johnhall  txt    REG    1,1   1265404 252878184 /opt/local/bin/lftp
lftp    41294 johnhall  txt    REG    1,1    291868 249919774 /opt/local/lib/libexpat.1.dylib
lftp    41294 johnhall  txt    REG    1,1    728812 250095356 /opt/local/lib/libssl.1.0.0.dylib
lftp    41294 johnhall  txt    REG    1,1   3158280 250095353 /opt/local/lib/libcrypto.1.0.0.dylib
lftp    41294 johnhall  txt    REG    1,1    107612 249988105 /opt/local/lib/libintl.8.dylib
lftp    41294 johnhall  txt    REG    1,1   2116812 249929212 /opt/local/lib/libiconv.2.dylib
lftp    41294 johnhall  txt    REG    1,1    450064 250208228 /opt/local/lib/libreadline.6.2.dylib
lftp    41294 johnhall  txt    REG    1,1    580492 249944158 /opt/local/lib/libncurses.5.dylib
lftp    41294 johnhall  txt    REG    1,1    165796 249991346 /opt/local/lib/libz.1.2.7.dylib
lftp    41294 johnhall  txt    REG    1,1    600576 249366287 /usr/lib/dyld
lftp    41294 johnhall  txt    REG    1,1 301068288 249682319 /private/var/db/dyld/dyld_shared_cache_x86_64
lftp    41294 johnhall    0u   CHR   16,0   0t77789       811 /dev/ttys000
lftp    41294 johnhall    1u   CHR   16,0   0t77789       811 /dev/ttys000
lftp    41294 johnhall    2u   CHR   16,0   0t77789       811 /dev/ttys000
lftp    41294 johnhall    3r   DIR    1,1      3128 249682893 /usr/local/bin
bash-3.2$

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Remember to use WikiFormatting when writing in Trac.

So it looks like the difference is that you are using GnuTLS whereas we are using OpenSSL. In that case, try installing the lftp port with the tls variant instead and see if that helps:

$ port variants lftp
lftp has the variants:
   tls: Use GnuTLS instead of OpenSSL
   universal: Build for multiple architectures
$ sudo port install lftp +tls

comment:4 Changed 9 years ago by jackh48@…

Sadly, still fails using variant tls.

comment:5 Changed 9 years ago by ryandesign (Ryan Schmidt)

Ok, so what's the difference between our build and yours now?

comment:6 Changed 9 years ago by jackh48@…

macport uses clang but local install uses /usr/bin/gcc

Don't know how to override this behaviour, and if I could, why (how?) does this affect other installers? ie. Why should it be overridden?

comment:7 Changed 7 years ago by ryandesign (Ryan Schmidt)

lftp is currently at version 4.4.13. Does that still have the problem? If so, what commands are you running exactly, so that I could try to reproduce it on my system?

comment:8 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Cc Me!

comment:9 Changed 7 years ago by neverpanic (Clemens Lang)

Owner: changed from macports-tickets@… to cal@…

This works for me. Please re-open and provide a crash log if this still occurs.

comment:10 Changed 7 years ago by neverpanic (Clemens Lang)

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.