Opened 9 years ago

Closed 9 years ago

#35534 closed defect (fixed)

p5.12-tk build fails: Cannot find X include files anywhere

Reported by: tsuehpsyde@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: p5-tk

Description (last modified by ryandesign (Ryan Schmidt))

Trying to build cssh on Mountain Lion, but I get the following error:

$ sudo port install cssh
--->  Computing dependencies for cssh
--->  Dependencies to be installed: p5.12-tk
--->  Building p5.12-tk
Error: org.macports.build for port p5.12-tk returned: command execution failed
Error: Failed to install p5.12-tk
Please see the log file for port p5.12-tk for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-tk/p5.12-tk/main.log
Error: The following dependencies were not installed: p5.12-tk
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port cssh failed

Digging in a bit, it throws an exit code two. Tracking it down, it appears to be that make all is missing?

$ cat /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-tk/p5.12-tk/main.log
version:1
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 501
:debug:main euid changed to: 502
:debug:main Executing org.macports.main (p5.12-tk)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.archivefetch (p5.12-tk)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.fetch (p5.12-tk)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.checksum (p5.12-tk)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.extract (p5.12-tk)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.patch (p5.12-tk)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.configure (p5.12-tk)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:build build phase started at Sat Aug  4 19:22:35 CDT 2012
:notice:build --->  Building p5.12-tk
:debug:build Executing org.macports.build (p5.12-tk)
:debug:build Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-tk/p5.12-tk/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.8'
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-tk/p5.12-tk/work/Tk-804.029" && /usr/bin/make -j4 -w all'
:debug:build Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-tk/p5.12-tk/work/Tk-804.029" && /usr/bin/make -j4 -w all 
:info:build make: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-tk/p5.12-tk/work/Tk-804.029'
:info:build make: *** No rule to make target `all'.  Stop.
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-tk/p5.12-tk/work/Tk-804.029'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-tk/p5.12-tk/work/Tk-804.029" && /usr/bin/make -j4 -w all 
:info:build Exit code: 2
:error:build org.macports.build for port p5.12-tk returned: command execution failed
:debug:build Error code: CHILDSTATUS 97290 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: targets not executed for p5.12-tk: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:error:build Failed to install p5.12-tk
:debug:build couldn't open "/System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/tclIndex": no such file or directory
    while executing
"open [file join $dir tclIndex]"
:notice:build Please see the log file for port p5.12-tk for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-tk/p5.12-tk/main.log

And running the actual command itself:

$  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-tk/p5.12-tk/work/Tk-804.029" && /usr/bin/make -j4 -w all 
make: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-tk/p5.12-tk/work/Tk-804.029'
make: *** No rule to make target `all'.  Stop.
make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_perl_p5-tk/p5.12-tk/work/Tk-804.029'

Not sure how to go about fixing it, but would love to get cssh working! Any help is appreciated.

Thanks!

-Jim tsuehpsyde@…

Attachments (1)

main.log (8.5 KB) - added by tsuehpsyde@… 9 years ago.
main.log from failed build of p5.12-tk on OS X 10.8 Mountain Lion

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: p5-tk added

First, "sudo port clean p5.12-tk" and try again. If it fails again, attach (not paste) the new main.log to this ticket. Remember to use WikiFormatting when writing in Trac.

Changed 9 years ago by tsuehpsyde@…

Attachment: main.log added

main.log from failed build of p5.12-tk on OS X 10.8 Mountain Lion

comment:2 in reply to:  1 Changed 9 years ago by tsuehpsyde@…

Replying to ryandesign@…:

First, "sudo port clean p5.12-tk" and try again. If it fails again, attach (not paste) the new main.log to this ticket. Remember to use WikiFormatting when writing in Trac.

Ran the port clean and retried the build; same failure. main.log attached as requested.

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned
Summary: p5.12-tk won't build on Mountain Lionp5.12-tk build fails: Cannot find X include files anywhere

Ah yes, the new log shows us that the problem is in the configure phase, which said:

:info:configure Cannot find X include files via /usr/X11R6/include
:info:configure Cannot find X include files anywhere.

And as a result didn't create a Makefile, yet then proceeded on as if nothing was wrong, leading to the error in the build phase that you saw before:

:info:build make: *** No rule to make target `all'.  Stop.

The port just needs to be told to look for X11 where MacPorts installs it.

comment:4 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.