Opened 9 years ago

Closed 9 years ago

#35644 closed defect (duplicate)

libmikmod does not compile on Mountain Lion

Reported by: g@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: mountainlion Cc: ryandesign (Ryan Schmidt), raimue (Rainer Müller)
Port: libmikmod

Description (last modified by ryandesign (Ryan Schmidt))

--->  Building libmikmod
Error: org.macports.build for port libmikmod returned: command execution failed
Please see the log file for port libmikmod for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_audio_libmikmod/libmikmod/main.log
Error: Problem while installing libmikmod
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
:info:build Making all in libmikmod
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_audio_libmikmod/libmikmod/work/libmikmod-3.2.0-beta2-i386/libmikmod'
:info:build /bin/sh ../libtool --mode=link /usr/bin/clang -arch i386 -version-info 3:0:0 -o libmikmod.la   drv_AF.lo drv_aiff.lo drv_aix.lo drv_alsa.lo drv_esd.lo drv_hp.lo drv_nos.lo drv_oss.lo drv_osx.lo drv_mac.lo drv_pipe.lo drv_raw.lo drv_sam9407.lo drv_sgi.lo drv_stdout.lo drv_sun.lo drv_ultra.lo drv_wav.lo load_669.lo load_amf.lo load_asy.lo load_dsm.lo load_far.lo load_gdm.lo load_it.lo load_imf.lo load_m15.lo load_med.lo load_mod.lo load_mtm.lo load_okt.lo load_s3m.lo load_stm.lo load_stx.lo load_ult.lo load_uni.lo load_xm.lo mmalloc.lo mmerror.lo mmio.lo mdriver.lo mdreg.lo mdulaw.lo mloader.lo mlreg.lo mlutil.lo mplayer.lo munitrk.lo mwav.lo npertab.lo sloader.lo virtch.lo virtch2.lo virtch_common.lo -framework CoreAudio -Wl,-framework,CoreAudio -L/opt/local/lib   -rpath /opt/local/lib
:info:build rm -fr .libs/libmikmod.la .libs/libmikmod.* .libs/libmikmod.*
:info:build /usr/bin/clang -arch i386 -r -keep_private_externs -nostdlib -o .libs/libmikmod.3.0.0.dylib-master.o  drv_AF.lo drv_aiff.lo drv_aix.lo drv_alsa.lo drv_esd.lo drv_hp.lo drv_nos.lo drv_oss.lo drv_osx.lo drv_mac.lo drv_pipe.lo drv_raw.lo drv_sam9407.lo drv_sgi.lo drv_stdout.lo drv_sun.lo drv_ultra.lo drv_wav.lo load_669.lo load_amf.lo load_asy.lo load_dsm.lo load_far.lo load_gdm.lo load_it.lo load_imf.lo load_m15.lo load_med.lo load_mod.lo load_mtm.lo load_okt.lo load_s3m.lo load_stm.lo load_stx.lo load_ult.lo load_uni.lo load_xm.lo mmalloc.lo mmerror.lo mmio.lo mdriver.lo mdreg.lo mdulaw.lo mloader.lo mlreg.lo mlutil.lo mplayer.lo munitrk.lo mwav.lo npertab.lo sloader.lo virtch.lo virtch2.lo virtch_common.lo && /usr/bin/clang -arch i386 -dynamiclib -flat_namespace -undefined suppress -o .libs/libmikmod.3.0.0.dylib .libs/libmikmod.3.0.0.dylib-master.o  -L/opt/local/lib -lc -framework CoreAudio -install_name /opt/local/lib/libmikmod.3.dylib -compatibility_version 4 -current_version 4.0
:info:build ld: in /opt/local/lib/libxml2.2.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /opt/local/lib/libxml2.2.dylib for architecture i386
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:build make[2]: *** [libmikmod.la] Error 1
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_audio_libmikmod/libmikmod/work/libmikmod-3.2.0-beta2-i386/libmikmod'
:info:build make[1]: *** [all-recursive] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_audio_libmikmod/libmikmod/work/libmikmod-3.2.0-beta2-i386'
:info:build make: *** [all-recursive-am] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_audio_libmikmod/libmikmod/work/libmikmod-3.2.0-beta2-i386'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_audio_libmikmod/libmikmod/work/libmikmod-3.2.0-beta2-i386" && /usr/bin/make -j4 -w all 
:info:build Exit code: 2
:error:build org.macports.build for port libmikmod returned: command execution failed
:debug:build Error code: NONE
:debug:build Backtrace: command execution failed
    while executing
"$procedure $targetname"
:info:build Warning: targets not executed for libmikmod: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Please see the log file for port libmikmod for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_audio_libmikmod/libmikmod/main.log

Change History (6)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Description: modified (diff)
Keywords: mountainlion added
Port: libmikmod added

libmikmod installs fine for me on Mountain Lion.

ld: in /opt/local/lib/libxml2.2.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /opt/local/lib/libxml2.2.dylib for architecture i386

That's a pretty strange message. I found a few occurrences of it via Google but didn't see a conclusive solution. But it makes me think that some part of your developer tools, possibly ld, is out of date. Please ensure that you have installed Xcode 4.4.1 via the Mac App Store, and opened Xcode and gone to its Preferences window, to the Downloads tab, and installed the latest Command Line Tools from there.

comment:2 Changed 9 years ago by raimue (Rainer Müller)

Cc: raimue@… added

I can reproduce this issue with the +universal build, while building for x86_64 alone works fine. None of the files mentioned on this command line seem to link to libxml*.dylib, which leaves me puzzled why this message appears at all.

comment:3 Changed 9 years ago by codebard@…

I was able to get past this by uninstalling libsdl_mixer +universal. Seems the problem on my end is lack of a i386 libstdc++:

:info:build /usr/bin/clang -arch i386 -r -keep_private_externs -nostdlib -o .libs/libmikmod.3.0.0.dylib-master.o  drv_AF.lo drv_aiff.lo drv_aix.lo drv_alsa.lo drv_esd.lo drv_hp.lo drv_nos.lo drv_oss.lo drv_osx.lo drv_mac.lo drv_pipe.lo drv_raw.lo drv_sam9407.lo drv_sgi.lo drv_stdout.lo drv_sun.lo drv_ultra.lo drv_wav.lo load_669.lo load_amf.lo load_asy.lo load_dsm.lo load_far.lo load_gdm.lo load_it.lo load_imf.lo load_m15.lo load_med.lo load_mod.lo load_mtm.lo load_okt.lo load_s3m.lo load_stm.lo load_stx.lo load_ult.lo load_uni.lo load_xm.lo mmalloc.lo mmerror.lo mmio.lo mdriver.lo mdreg.lo mdulaw.lo mloader.lo mlreg.lo mlutil.lo mplayer.lo munitrk.lo mwav.lo npertab.lo sloader.lo virtch.lo virtch2.lo virtch_common.lo && /usr/bin/clang -arch i386 -dynamiclib -flat_namespace -undefined suppress -o .libs/libmikmod.3.0.0.dylib .libs/libmikmod.3.0.0.dylib-master.o  -L/opt/local/lib -lc -framework CoreAudio -install_name /opt/local/lib/libmikmod.3.dylib -compatibility_version 4 -current_version 4.0
:info:build ld: in /opt/local/lib/libstdc++.6.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /opt/local/lib/libstdc++.6.dylib for architecture i386
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:build make[2]: *** [libmikmod.la] Error 1

comment:4 Changed 9 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: newclosed

Updated libmikmod to version 3.2.0 in r99557. This solved the problem for me. Please report back if you are still experiencing issues as I am not entirely sure what caused this error after all.

Last edited 9 years ago by raimue (Rainer Müller) (previous) (diff)

comment:5 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

comment:6 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: reopenedclosed

Duplicate of #36438.

Note: See TracTickets for help on using tickets.