Opened 8 years ago

Closed 8 years ago

#35711 closed defect (duplicate)

[rvm] [1.05] Only compiles with llvm-gcc4.2 in OSX 10.8 (Xcode 4.4.1)

Reported by: flo.thiel+macports@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: rvm

Description

rvm 1.0.5 compilation breaks under OSX 10.8, Xcode 4.4.1, works using configure.compiler=llvm-gcc-4.2

Attachments (2)

main.log (24.5 KB) - added by edlyuu@… 8 years ago.
first error running on xcode 4.5.2
main.2.log (128.3 KB) - added by edlyuu@… 8 years ago.
second undefined symbol error

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by mf2k (Frank Schima)

Port: rvm added

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Please attach a main.log showing the build failure.

Changed 8 years ago by edlyuu@…

Attachment: main.log added

first error running on xcode 4.5.2

comment:3 Changed 8 years ago by edlyuu@…

I've attached the main.log while running a fresh install of OSX 10.8.2 and xcode 4.5.2. The first error is easily fixed by changing AM_CONFIG_HEADER to AC_CONFIG_HEADERS in configure.in. (Ideally, it should be named configure.ac)

comment:4 Changed 8 years ago by edlyuu@…

After changing that AC_CONFIG_HEADERS, I encountered the following error:

:info:build Undefined symbols for architecture x86_64:
:info:build   "double const max_limit<double>()", referenced from:
:info:build       test4() in test-rmath.o
:info:build   "float const max_limit<float>()", referenced from:
:info:build       test4() in test-rmath.o
:info:build   "double const min_limit<double>()", referenced from:
:info:build       test4() in test-rmath.o
:info:build   "float const min_limit<float>()", referenced from:
:info:build       test4() in test-rmath.o
:info:build ld: symbol(s) not found for architecture x86_64
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:build make[1]: *** [test-rmath] Error 1
:info:build mv -f .deps/test-vaulter-006.Tpo .deps/test-vaulter-006.Po
:info:build mv -f .deps/test-rvm-002.Tpo .deps/test-rvm-002.Po
:info:build mv -f .deps/test-rvm-003.Tpo .deps/test-rvm-003.Po
:info:build mv -f .deps/test-rvm-001.Tpo .deps/test-rvm-001.Po
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_rvm/rvm/work/rvm-1.05'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_rvm/rvm/work/rvm-1.05'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_rvm/rvm/work/rvm-1.05" && /usr/bin/make -j8 -w all
:info:build Exit code: 2
:error:build org.macports.build for port rvm returned: command execution failed
:debug:build Error code: CHILDSTATUS 4285 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: targets not executed for rvm: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Please see the log file for port rvm for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_rvm/rvm/main.log
Last edited 8 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

Changed 8 years ago by edlyuu@…

Attachment: main.2.log added

second undefined symbol error

comment:5 Changed 8 years ago by edlyuu@…

I can verify that with sudo port install rvm configure.compiler=llvm-gcc-4.2, the port will build AFTER fixing the AM_CONFIG_HEADERS. It would be nice if rvm builds without the configure.compiler flag.

Last edited 8 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:6 in reply to:  5 Changed 8 years ago by ryandesign (Ryan Schmidt)

Replying to edlyuu@…:

the port will build AFTER fixing the AM_CONFIG_HEADERS

This part is fixed in r101934.

comment:7 in reply to:  4 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: duplicate
Status: newclosed

Replying to edlyuu@…:

:info:build Undefined symbols for architecture x86_64:

This part is a duplicate of #32180.

Note: See TracTickets for help on using tickets.