Opened 7 years ago

Closed 4 years ago

#35713 closed defect (fixed)

wyrd @ 1.4.4 configure halts with ocaml 4.0.0

Reported by: bxf4@… Owned by: henry@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: haspatch Cc:
Port: wyrd

Description

Hello, I tried to install wyrd yesterday and it halted in configure when checking the OCAML version. It is looking for 3.0.8 or greater, but the logic in configure.in looks weird. (I don't know bash testing logic well, though.)

Here's the error section from the log:

...
:debug:configure Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_wyrd/wyrd/work/wyrd-1.4.4" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man'
:debug:configure Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_wyrd/wyrd/work/wyrd-1.4.4" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man 
:info:configure checking for ocamlc... ocamlc
:info:configure ocaml version is 4.00.0
:info:configure ocaml library path is /opt/local/lib/ocaml
:info:configure configure: error: Wyrd requires OCaml version 3.08 or greater.
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_wyrd/wyrd/work/wyrd-1.4.4" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man 
:info:configure Exit code: 1
:error:configure org.macports.configure for port wyrd returned: configure failure: command execution failed

I installed macports autoconf, tried to sensibly alter the OCAML version checking in configure.in, but didn't succeed. I then commented the OCAML version checking logic in configure.in, ran autoconf, and then re-ran port install wyrd. It appears to have worked.

Attachments (2)

configure.patch (545 bytes) - added by jmroot (Joshua Root) 7 years ago.
Portfile.patch (304 bytes) - added by jmroot (Joshua Root) 7 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Keywords: wyrd ocaml removed
Owner: changed from macports-tickets@… to henry@…
Port: wyrd added; wyrd-1.4.4 removed

In the future, please Cc the port maintainer(s).

Changed 7 years ago by jmroot (Joshua Root)

Attachment: configure.patch added

Changed 7 years ago by jmroot (Joshua Root)

Attachment: Portfile.patch added

comment:2 Changed 7 years ago by jmroot (Joshua Root)

See if the attached patch to the configure script works for you.

comment:3 Changed 7 years ago by jmroot (Joshua Root)

Keywords: haspatch added

comment:4 Changed 7 years ago by bxf4@…

I finally had time to try it and yes, it worked. I couldn't figure out how to get port to find and use configure.patch, but I applied it by hand and wyrd built successfully. Thank you!

comment:5 Changed 4 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.