Opened 7 years ago

Closed 7 years ago

#35882 closed update (fixed)

cmake @ 2.8.9 - Updated Portfile

Reported by: samuel@… Owned by: cssdev
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: haspatch Cc: anddam (Andrea D'Amore), help@…
Port: cmake

Description

This updated Portfile installs cmake 2.8.9.

Attachments (1)

Portfile (2.8 KB) - added by samuel@… 7 years ago.

Download all attachments as: .zip

Change History (14)

Changed 7 years ago by samuel@…

Attachment: Portfile added

comment:1 Changed 7 years ago by samuel@…

The main concern I have is whether the previous patches for 2.8.8 are still necessary. I replaced my existing Portfile for 2.8.8 and everything is working fine. But perhaps some of the patches can be removed?

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Keywords: haspatch added
Owner: changed from macports-tickets@… to css@…

Please attach a unified diff of your changes instead of a complete new Portfile; this will make it easier to review your changes.

comment:3 Changed 7 years ago by samuel@…

How do I do that?

comment:5 Changed 7 years ago by samuel@…

Hi,

I'll do that in the future but right now I don't have the original Portfile since I just updated it in-place. Therefore, if someone else can do that diff that would be great. The only change was the version and the checksums.

Kind regards, Samuel

comment:6 Changed 7 years ago by cssdev

Status: newassigned

I'm traveling and don't have access to my Mac, but I can check on this and some Other port tickets this weekend.

comment:7 Changed 7 years ago by cssdev

Resolution: fixed
Status: assignedclosed

Fixed in r97601!

comment:8 Changed 7 years ago by anddam (Andrea D'Amore)

Cc: and.damore@… help@… added
Resolution: fixed
Status: closedreopened

Reopening update ticket, it seems that patchfile patch-Modules_FindPkgConfig_cmake.diff should have been removed, see following quote:

Replying to help@…:

cmake version was bumped in Portfile, but this patch wasn't dropped. In result pkg-config support in cmake broke. Please revert this change. Tested using local overlay, removing patch-Modules_FindPkgConfig_cmake.diff from patchfiles works.

That said can you show an example of the issue that is affecting cmake at the moment so we can reproduce it?

By this patch you mean patch-Modules_FindPkgConfig_cmake.diff, right?

comment:9 Changed 7 years ago by cssdev

So the issue noted in #34505 was fixed in CMake 2.8.9, so the included patch to FindPkgConfig is no longer needed and should be removed. I'll bump the revision for the fix.

comment:10 Changed 7 years ago by cssdev

Fixed in r97867

comment:11 in reply to:  9 Changed 7 years ago by anddam (Andrea D'Amore)

Replying to css@…:

So the issue noted in #34505 was fixed in CMake 2.8.9, so the included patch to FindPkgConfig is no longer needed and should be removed.

I'd wait to see what the error actually is.

comment:12 Changed 7 years ago by help@…

exactly as in #34505 description - PKG_CONFIG_FOUND variable doesn't get set.

comment:13 Changed 7 years ago by anddam (Andrea D'Amore)

Resolution: fixed
Status: reopenedclosed

I confirm that avidemux's configure phase works correctly using after r97867 cmake port and fails using cmake before that revision.

Ticket closed.

Note: See TracTickets for help on using tickets.