Opened 8 years ago

Closed 4 years ago

#35895 closed defect (fixed)

pidgin-encryption: add pkgconfig dependency and license

Reported by: ryandesign (Ryan Schmidt) Owned by: rsync@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: haspatch Cc: kurthindenburg (Kurt Hindenburg)
Port: pidgin-encryption

Description

In fixing pidgin-encryption for compatibility with glib 2.32 in #35883 I learned from the buildbot that a pkgconfig dependency is needed. And the automated lint report reminded me that the port should indicate its license. The attached patch fixes these. May I commit it?

You'll note I put the depends_build under the checksums, instead of near where the depends_lib line is. With your permission I'd like to make a second commit to move the depends_lib down there as well, to change tabs to spaces, add the standard modeline, and make a couple other minor formatting and whitespace adjustments to make this portfile more similar to others.

Attachments (1)

pidgin-encryption.diff (591 bytes) - added by ryandesign (Ryan Schmidt) 8 years ago.

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by ryandesign (Ryan Schmidt)

Attachment: pidgin-encryption.diff added

comment:1 Changed 4 years ago by kurthindenburg (Kurt Hindenburg)

Cc: khindenburg@… added
Resolution: fixed
Status: newclosed

pkgconfig dep was already added - added license r153915

Note: See TracTickets for help on using tickets.