Opened 15 years ago

Closed 14 years ago

#3634 closed defect (fixed)

BUG: wget fail unless gettext installed before, but gettext is not a dependency

Reported by: nirs@… Owned by: yeled@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: mww@…
Port:

Description

If you try to install wget, you get build errors about msgfmt and other gettext stuff. If you install gettext you can later install wget with no error.

reproduce:

  1. sudo port install wget -> you get this hairy error:

---> Building wget with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_net_wget/work/ wget-1.10" && make all" returned error 2 Command output: gcc -I. -I. -DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/opt/local/etc/wgetrc\" -DLOCALEDIR=\"/opt/local/share/locale\" -O2 -Wall -Wno-implicit -c res.c gcc -I. -I. -DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/opt/local/etc/wgetrc\" -DLOCALEDIR=\"/opt/ local/share/locale\" -O2 -Wall -Wno-implicit -c retr.c gcc -I. -I. -DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/opt/local/etc/wgetrc\" -DLOCALEDIR=\"/opt/ local/share/locale\" -O2 -Wall -Wno-implicit -c safe-ctype.c gcc -I. -I. -DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/opt/local/etc/wgetrc\" -DLOCALEDIR=\"/opt/ local/share/locale\" -O2 -Wall -Wno-implicit -c snprintf.c gcc -I. -I. -DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/opt/local/etc/wgetrc\" -DLOCALEDIR=\"/opt/ local/share/locale\" -O2 -Wall -Wno-implicit -c openssl.c openssl.c: In function `ssl_connect': openssl.c:341: warning: field width is not type int (arg 3) gcc -I. -I. -DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/opt/local/etc/wgetrc\" -DLOCALEDIR=\"/opt/ local/share/locale\" -O2 -Wall -Wno-implicit -c url.c gcc -I. -I. -DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/opt/local/etc/wgetrc\" -DLOCALEDIR=\"/opt/ local/share/locale\" -O2 -Wall -Wno-implicit -c utils.c gcc -I. -I. -DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/opt/local/etc/wgetrc\" -DLOCALEDIR=\"/opt/ local/share/locale\" -O2 -Wall -Wno-implicit -c version.c gcc -I. -I. -DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/opt/local/etc/wgetrc\" -DLOCALEDIR=\"/opt/ local/share/locale\" -O2 -Wall -Wno-implicit -c xmalloc.c /bin/sh ../libtool --mode=link gcc -O2 -Wall -Wno-implicit -o wget cmpt.o connect.o convert.o cookies.o ftp.o ftp-basic.o ftp-ls.o ftp-opie.o hash.o host.o html-parse.o html-url.o http.o http- ntlm.o init.o log.o main.o gen-md5.o netrc.o progress.o ptimer.o recur.o res.o retr.o safe-ctype.o snprintf.o openssl.o url.o utils.o version.o xmalloc.o -lintl -lssl -lcrypto -ldl mkdir .libs gcc -O2 -Wall -Wno-implicit -o wget cmpt.o connect.o convert.o cookies.o ftp.o ftp-basic.o ftp-ls.o ftp-opie.o hash.o host.o html-parse.o html-url.o http.o http-ntlm.o init.o log.o main.o gen-md5.o netrc.o progress.o ptimer.o recur.o res.o retr.o safe-ctype.o snprintf.o openssl.o url.o utils.o version.o xmalloc.o /usr/local/lib/libintl.dylib /usr/lib/libiconv.dylib -lc -lssl -lcrypto -ldl ld: warning prebinding disabled because dependent library: /usr/local/lib/libintl.3.dylib is not prebound ld: warning multiple definitions of symbol _locale_charset /usr/local/lib/libintl.dylib(localcharset.o) definition of _locale_charset /usr/lib/libiconv.dylib(localcharset.o) definition of _locale_charset cd doc && make CC='gcc' CPPFLAGS= DEFS='-DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/opt/local/ etc/wgetrc\" -DLOCALEDIR=\"/opt/local/share/locale\"' CFLAGS='-O2 -Wall -Wno-implicit' LDFLAGS= LIBS='-lintl -lssl -lcrypto -ldl ' prefix='/opt/local' exec_prefix='/opt/local' bindir='/opt/ local/bin' infodir='/opt/local/share/info' mandir='/opt/local/share/man' manext='1' sed 's,#! /usr/bin/perl,#! /usr/bin/perl,' texi2pod.pl.in > texi2pod.pl chmod u+x texi2pod.pl ./texi2pod.pl ./wget.texi wget.pod Option VERSION not defined /usr/bin/pod2man --center="GNU Wget" --release="GNU Wget 1.10" wget.pod > wget.1 cd po && make CC='gcc' CPPFLAGS= DEFS='-DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/opt/local/etc/ wgetrc\" -DLOCALEDIR=\"/opt/local/share/locale\"' CFLAGS='-O2 -Wall -Wno-implicit' LDFLAGS= LIBS='-lintl -lssl -lcrypto -ldl ' prefix='/opt/local' exec_prefix='/opt/local' bindir='/opt/local/bin' infodir='/opt/local/share/info' mandir='/opt/local/share/man' manext='1' file=./echo bg | sed 's,.*/,,'.gmo \

&& rm -f $file && PATH=../src:$PATH msgfmt -o $file bg.po

/bin/sh: line 1: msgfmt: command not found make[1]: * [bg.gmo] Error 127 make: * [po] Error 2

Workaround:

  1. sudo port install gettext
  2. sudo port install wget

Works.

But: port deps wget wget has no dependencies

?!

Change History (6)

comment:1 Changed 15 years ago by mww@…

Owner: changed from darwinports-bugs@… to yeled@…

works flawless w/o gettext on 10.4;

comment:2 Changed 15 years ago by nirs@…

But 10.4 is generally broken and not ready for use currently :-)

The problem is either the version of gettext: on 10.3. you get 0.14.1 in /usr, while darwinport install 0.14.3, or maybe it broken install in 10.3.

Anyway, the port should not count on the exiting system. If gettext is used while installing wget, it should be a dependency. Or maybe don't use gettext - its strange that building needs gettext, it is usually needed as a development tool, not by end users.

comment:3 Changed 15 years ago by mww@…

Cc: mww@… added

can you safely remove gettext after having build wget? (w/o breaking wget..)

comment:4 Changed 15 years ago by nirs@…

(In reply to comment #3)

can you safely remove gettext after having build wget? (w/o breaking wget..)

Yea. I download few pages with wget after uninstalling gettext, and it seems fine. I don't see why wget should use gettext, looks like it uses it just for the build process.

comment:5 Changed 15 years ago by mww@…

Summary: wget fail unless gettext installed before, but gettext is not a dependencyBUG: wget fail unless gettext installed before, but gettext is not a dependency

comment:6 Changed 14 years ago by mww@…

Resolution: fixed
Status: newclosed

I've just added the dependency on gettext incl. fixing the compiler flags so wget finds the libs etc. - if this does not resolve your issue (can't test on 10.3 myself), please re-open this bug!

Note: See TracTickets for help on using tickets.