Opened 5 years ago

Closed 5 years ago

#36381 closed defect (fixed)

mongodb: version 2.2.0 won't build under Mac OS 10.5

Reported by: heapifyman@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: leopard Cc:
Port: mongodb

Description (last modified by ryandesign (Ryan Schmidt))

After issue #35118 had been fixed I tried to upgrade mongodb to the latest version but I got a build error.

I uninstalled boost befor upgrading as I assumed that mongodb port now comes with its own boost version.

Both upgrade and complete uninstall and re-install of mongodb failed. See error message below.

I'm using Mac OS X 10.5.

error message in log file:

:info:build /usr/bin/g++-4.0 -o build/darwin/cc__usr_bin_gcc-4.0/cxx__usr_bin_g++-4.0/extralib_pcre_pcrecpp_js_snappy/use-system-pcre/use-system-sm/use-system-snappy/mongo/platform/atomic_word_test.o -c -Wnon-virtual-dtor -Woverloaded-virtual -arch i386 -fPIC -fno-strict-aliasing -ggdb -pthread -Wall -Wsign-compare -Wno-unknown-pragmas -Winvalid-pch -O3 -DBOOST_ALL_NO_LIB -D_SCONS -DMONGO_EXPOSE_MACROS -DSUPPORT_UTF8 -D_FILE_OFFSET_BITS=64 -DJS_C_STRINGS_ARE_UTF8 -DMONGO_HAVE_HEADER_UNISTD_H -DMONGO_HAVE_EXECINFO_BACKTRACE -DXP_UNIX -Ibuild/darwin/cc__usr_bin_gcc-4.0/cxx__usr_bin_g++-4.0/extralib_pcre_pcrecpp_js_snappy/use-system-pcre/use-system-sm/use-system-snappy/third_party/boost -Isrc/third_party/boost -Ibuild/darwin/cc__usr_bin_gcc-4.0/cxx__usr_bin_g++-4.0/extralib_pcre_pcrecpp_js_snappy/use-system-pcre/use-system-sm/use-system-snappy -Isrc -Ibuild/darwin/cc__usr_bin_gcc-4.0/cxx__usr_bin_g++-4.0/extralib_pcre_pcrecpp_js_snappy/use-system-pcre/use-system-sm/use-system-snappy/mongo -Isrc/mongo -I/opt/local/include -I/opt/local/include/js src/mongo/platform/atomic_word_test.cpp
:info:build /var/tmp//cchCLoXM.s:3481:invalid character '%' in mnemonic
:info:build /var/tmp//cchCLoXM.s:3650:invalid character '%' in mnemonic
:info:build /var/tmp//cchCLoXM.s:3824:invalid character '%' in mnemonic
:info:build /var/tmp//cchCLoXM.s:3999:invalid character '%' in mnemonic
:info:build /var/tmp//cchCLoXM.s:7780:invalid character '%' in mnemonic
:info:build scons: *** [build/darwin/cc__usr_bin_gcc-4.0/cxx__usr_bin_g++-4.0/extralib_pcre_pcrecpp_js_snappy/use-system-pcre/use-system-sm/use-system-snappy/mongo/platform/atomic_word_test.o] Error 1
:info:build scons: building terminated because of errors.
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_mongodb/mongodb/work/mongodb-src-r2.2.0" && /opt/local/bin/scons -j2 all mongobridge mongosniff --cc=/usr/bin/gcc-4.0 --cxx=/usr/bin/g++-4.0 --full --use-system-pcre --use-system-sm --use-system-snappy --extralib=pcre,pcrecpp,js,snappy 
:info:build Exit code: 2
:error:build org.macports.build for port mongodb returned: command execution failed
:debug:build Error code: CHILDSTATUS 41904 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: targets not executed for mongodb: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Please see the log file for port mongodb for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_mongodb/mongodb/main.log

Change History (4)

comment:1 Changed 5 years ago by heapifyman@…

  • Cc heapifyman@… added

Cc Me!

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

  • Cc heapifyman@… removed
  • Description modified (diff)
  • Keywords mongodb removed
  • Owner changed from macports-tickets@… to ryandesign@…

I have not yet had a chance to test on Leopard.

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

There is an upstream bug report about their Leopard buildbot failing to build mongodb. They "fixed" it by upgrading their buildbot to Snow Leopard.

comment:4 Changed 5 years ago by ryandesign (Ryan Schmidt)

  • Resolution set to fixed
  • Status changed from new to closed

Ok, I was able to reproduce the error on Leopard. It seems mongodb doesn't like gcc 4.0. I was able to build it on Leopard with gcc 4.2. So this should be fixed for Leopard in r98291. For Tiger we could investigate using apple-gcc-4.2 but I haven't done so yet.

Note: See TracTickets for help on using tickets.