Opened 16 years ago

Closed 15 years ago

#3647 closed defect (fixed)

BUG: xmaxima broken

Reported by: ghenshaw@… Owned by: gwright@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

I just upgraded my maxima port from 5.9.0 to 5.9.1. Maxima (from the command line) runs fine, but xmaxima appears to be broken. Specifically, the Wish shell starts up and opens the maxima primer, but the maxima prompt never appears, and eventually a dialog box appears with the message "Starting maxima timed out. Wait longer?"

Change History (4)

comment:1 Changed 16 years ago by gwright@…

Status: newassigned

The new maxima builds with openmcl (clisp on OS X has become very bit rotted, and I don't have much hope for it building in the near future). OpenMCL is much more reliable, not just in the build process but the generated code.

I've got to modify the xmaxima script to set the underlying OpenMCL teminal process into nonblocking mode. This should (I hope) just involve modifying the xmaxima script.

In the future (i.e., after the maxima 5.9.2 release) the best way to use maximax will be via the TeXmacs front end. The TeXmacs port supports the new maxima plugin now; however, since maxima 5.9.2 has been delayed it only works with maxima build from cvs.

Greg

comment:2 Changed 15 years ago by mww@…

Summary: xmaxima brokenBUG: xmaxima broken

comment:3 Changed 15 years ago by blb@…

Owner: changed from darwinports-bugs@… to gwright@…
Status: assignednew

Assign to maintainer.

comment:4 Changed 15 years ago by gwright@…

Resolution: fixed
Status: newclosed

Closing out this old bug; it was resolved with the upgrade to maxima verison 5.9.2.

-Greg

Note: See TracTickets for help on using tickets.