Opened 8 years ago

Closed 8 years ago

#36539 closed defect (fixed)

libmatheval @1.1.8_0 build error - missing dependency

Reported by: shamardin@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: libmatheval

Description

Build of libmatheval fails like this:

...
:info:build ld: library not found for -lfl
:info:build clang: error: linker command failed with exit code 1 (use -v to see 
invocation)
:info:build make[2]: *** [libmatheval.la] Error 1
...

The problem is the missing dependency on flex port. Installing this port manually solves the problem.

Change History (4)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to mww@…

comment:2 Changed 8 years ago by jmroot (Joshua Root)

Hmm, I have /usr/lib/libfl.a here. What OS version are you on?

comment:3 Changed 8 years ago by shamardin@…

OS X 10.8.2, no /usr/lib/libfl.a, but works fine with /opt/local/lib/libfl.a from flex @2.5.37_1.

comment:4 Changed 8 years ago by mww@…

Resolution: fixed
Status: newclosed

Thanks -- I've just added the build-dependency in r99365

Note: See TracTickets for help on using tickets.