Opened 8 years ago

Closed 8 years ago

#36639 closed defect (duplicate)

jakarta-regexp : checksum mismatch because HTML file

Reported by: nic@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: jakarta-regexp

Description

Looks like some corruption. I noticed the portfile hasn't been updated in 12 months. I'm installing an a brand-new machine, but have tried changing DNS, and have reset caches...

sudo port clean --dist jakarta-regexp
--->  Cleaning jakarta-regexp
rosaline:macports nic$ sudo port install jakarta-regexp
--->  Computing dependencies for jakarta-regexp
--->  Fetching archive for jakarta-regexp
--->  Attempting to fetch jakarta-regexp-1.5_0.darwin_12.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/jakarta-regexp
--->  Attempting to fetch jakarta-regexp-1.5_0.darwin_12.x86_64.tbz2 from http://lil.fr.packages.macports.org/jakarta-regexp
--->  Attempting to fetch jakarta-regexp-1.5_0.darwin_12.x86_64.tbz2 from http://packages.macports.org/jakarta-regexp
--->  Fetching distfiles for jakarta-regexp
--->  Attempting to fetch jakarta-regexp-1.5.tar.gz from http://www.mirrorservice.org/sites/ftp.apache.org/jakarta/regexp/source
--->  Verifying checksum(s) for jakarta-regexp
Error: Checksum (md5) mismatch for jakarta-regexp-1.5.tar.gz
Error: Checksum (sha1) mismatch for jakarta-regexp-1.5.tar.gz
Error: Checksum (rmd160) mismatch for jakarta-regexp-1.5.tar.gz
***
The non-matching file appears to be HTML. See this page for possible reasons
for the checksum mismatch:
<https://trac.macports.org/wiki/MisbehavingServers>
***
Error: org.macports.checksum for port jakarta-regexp returned: Unable to verify file checksums
Please see the log file for port jakarta-regexp for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_java_jakarta-regexp/jakarta-regexp/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port jakarta-regexp failed

Attachments (1)

main.log (6.1 KB) - added by nic@… 8 years ago.

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by nic@…

Attachment: main.log added

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Summary: Checksum (md5) mismatch for jakarta-regexp-1.5.tar.gzjakarta-regexp : checksum mismatch because HTML file

Looks like some corruption.

No; it looks like you received an HTML file because upstream servers have changed. Duplicate of #36079.

Note: See TracTickets for help on using tickets.