Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#36692 closed defect (duplicate)

llvm-3.0 upgrade hangs

Reported by: rahsaan.page@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: cooljeanius (Eric Gallager)
Port: llvm-3.0

Description (last modified by ryandesign (Ryan Schmidt))

Hi Support Team,

i am running OSX 10.8.2 mountain lion, i always been a mac ports user, i been trying to upgrade all outdated packages for the longest while now, and it seem to get stuck at the build process for (llvm-3.0), using MacPorts base version 2.1.2 installed: here is a debug output where it get stucks:

--->  Building llvm-3.0
DEBUG: Executing org.macports.build (llvm-3.0)
DEBUG: Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_llvm-3.0/llvm-3.0/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.8' VERBOSE='1' REQUIRE_RTTI='1'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_llvm-3.0/llvm-3.0/work/llvm-3.0.src" && /usr/bin/make -j4 -w all'
DEBUG: Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_llvm-3.0/llvm-3.0/work/llvm-3.0.src" && /usr/bin/make -j4 -w all 

and here is a sample of the process:

Analysis of sampling make (pid 5422) every 1 millisecond
Process:         make [5422]
Path:            /usr/bin/make
Load Address:    0x10c6cb000
Identifier:      make
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  sh [5421]

Date/Time:       2012-10-22 22:21:57.583 -0400
OS Version:      Mac OS X 10.8.2 (12C60)
Report Version:  7

Call graph:
    2830 Thread_718280   DispatchQueue_1: com.apple.main-thread  (serial)
      2830 ???  (in make)  load address 0x10c6cb000 + 0x1524  [0x10c6cc524]
        2830 ???  (in make)  load address 0x10c6cb000 + 0xfb40  [0x10c6dab40]
          2830 ???  (in make)  load address 0x10c6cb000 + 0x126f7  [0x10c6dd6f7]
            2830 ???  (in make)  load address 0x10c6cb000 + 0x129f5  [0x10c6dd9f5]
              2830 ???  (in make)  load address 0x10c6cb000 + 0x13dc7  [0x10c6dedc7]
                2830 ???  (in make)  load address 0x10c6cb000 + 0x129f5  [0x10c6dd9f5]
                  2830 ???  (in make)  load address 0x10c6cb000 + 0x13e47  [0x10c6dee47]
                    2830 ???  (in make)  load address 0x10c6cb000 + 0x1aff5  [0x10c6e5ff5]
                      2830 ???  (in make)  load address 0x10c6cb000 + 0x1a13b  [0x10c6e513b]
                        2830 ???  (in make)  load address 0x10c6cb000 + 0x5e9d  [0x10c6d0e9d]
                          2830 ???  (in make)  load address 0x10c6cb000 + 0x5fac  [0x10c6d0fac]
                            2830 ???  (in make)  load address 0x10c6cb000 + 0x843e  [0x10c6d343e]
                              2830 ???  (in make)  load address 0x10c6cb000 + 0x9491  [0x10c6d4491]
                                2830 read  (in libsystem_kernel.dylib) + 10  [0x7fff92b33ffa]

Total number in stack (recursive counted multiple, when >=5):

Sort by top of stack, same collapsed (when >= 5):
        read  (in libsystem_kernel.dylib)        2830

Binary Images:
       0x10c6cb000 -        0x10c6efff7 +make (??? - ???) <97184ACB-B140-3A82-90B7-B3F4D3EE4907> /usr/bin/make
    0x7fff6c2cb000 -     0x7fff6c2ff93f  dyld (210.2 - ???) <A40597AA-5529-3337-8C09-D8A014EB1578> /usr/lib/dyld
    0x7fff877e4000 -     0x7fff877ecff7  libsystem_dnssd.dylib (??? - ???) <62AA0B84-188A-348B-8F9E-3E2DB08DB93C> /usr/lib/system/libsystem_dnssd.dylib
    0x7fff88003000 -     0x7fff88004ff7  libdnsinfo.dylib (453.18.0 - compatibility 1.0.0) <E7595861-ECF9-336E-9901-BED2620FAA80> /usr/lib/system/libdnsinfo.dylib
    0x7fff880d0000 -     0x7fff880d1ff7  libsystem_sandbox.dylib (??? - ???) <3C3B03CF-C525-3CB3-8557-62E91B93AC95> /usr/lib/system/libsystem_sandbox.dylib
    0x7fff8811f000 -     0x7fff8812dff7  libsystem_network.dylib (??? - ???) <0D99F24E-56FE-380F-B81B-4A4C630EE587> /usr/lib/system/libsystem_network.dylib
    0x7fff88468000 -     0x7fff88469ff7  libremovefile.dylib (23.1.0 - compatibility 1.0.0) <DBBFAF35-AC78-3856-92F6-6E4FD9DF14A2> /usr/lib/system/libremovefile.dylib
    0x7fff8846a000 -     0x7fff884b6ff7  libauto.dylib (??? - ???) <73CDC482-16E3-3FC7-9BB4-FBA2DA44DBC2> /usr/lib/libauto.dylib
    0x7fff89755000 -     0x7fff8976aff7  libdispatch.dylib (228.23.0 - compatibility 1.0.0) <D26996BF-FC57-39EB-8829-F63585561E09> /usr/lib/system/libdispatch.dylib
    0x7fff89779000 -     0x7fff89781fff  liblaunch.dylib (442.26.2 - compatibility 1.0.0) <2F71CAF8-6524-329E-AC56-C506658B4C0C> /usr/lib/system/liblaunch.dylib
    0x7fff899ff000 -     0x7fff89a0dfff  libcommonCrypto.dylib (50000.0.0 - compatibility 1.0.0) <2D6537F5-1B5E-305C-A1CF-D1FA80CA3939> /usr/lib/system/libcommonCrypto.dylib
    0x7fff89d93000 -     0x7fff89db8ff7  libc++abi.dylib (24.4.0 - compatibility 1.0.0) <E7BD9363-1D25-3551-A68A-2E2FF6ABECD7> /usr/lib/libc++abi.dylib
    0x7fff8ac06000 -     0x7fff8ac0dfff  libcopyfile.dylib (89.0.0 - compatibility 1.0.0) <876573D0-E907-3566-A108-577EAD1B6182> /usr/lib/system/libcopyfile.dylib
    0x7fff8b5df000 -     0x7fff8b615fff  libsystem_info.dylib (??? - ???) <4FFCA242-7F04-365F-87A6-D4EFB89503C1> /usr/lib/system/libsystem_info.dylib
    0x7fff8b6bf000 -     0x7fff8b6c1ff7  libunc.dylib (25.0.0 - compatibility 1.0.0) <92805328-CD36-34FF-9436-571AB0485072> /usr/lib/system/libunc.dylib
    0x7fff8bbde000 -     0x7fff8bc00ff7  libxpc.dylib (140.41.0 - compatibility 1.0.0) <FAC04D8B-680E-325F-8F0C-DD69859D0E01> /usr/lib/system/libxpc.dylib
    0x7fff8beff000 -     0x7fff8bf00fff  libsystem_blocks.dylib (59.0.0 - compatibility 1.0.0) <D92DCBC3-541C-37BD-AADE-ACC75A0C59C8> /usr/lib/system/libsystem_blocks.dylib
    0x7fff8c389000 -     0x7fff8c38cff7  libdyld.dylib (210.2.3 - compatibility 1.0.0) <F59367C9-C110-382B-A695-9035A6DD387E> /usr/lib/system/libdyld.dylib
    0x7fff8ebc1000 -     0x7fff8ebc1fff  libkeymgr.dylib (25.0.0 - compatibility 1.0.0) <CC9E3394-BE16-397F-926B-E579B60EE429> /usr/lib/system/libkeymgr.dylib
    0x7fff8fd07000 -     0x7fff8fd0cfff  libcache.dylib (57.0.0 - compatibility 1.0.0) <65187C6E-3FBF-3EB8-A1AA-389445E2984D> /usr/lib/system/libcache.dylib
    0x7fff8fd75000 -     0x7fff8fdddff7  libc++.1.dylib (65.1.0 - compatibility 1.0.0) <20E31B90-19B9-3C2A-A9EB-474E08F9FE05> /usr/lib/libc++.1.dylib
    0x7fff90385000 -     0x7fff90451fe7  libsystem_c.dylib (825.25.0 - compatibility 1.0.0) <8CBCF9B9-EBB7-365E-A3FF-2F3850763C6B> /usr/lib/system/libsystem_c.dylib
    0x7fff90509000 -     0x7fff9062192f  libobjc.A.dylib (228.0.0 - compatibility 1.0.0) <90D31928-F48D-3E37-874F-220A51FD9E37> /usr/lib/libobjc.A.dylib
    0x7fff9089a000 -     0x7fff908a0fff  libmacho.dylib (829.0.0 - compatibility 1.0.0) <BF332AD9-E89F-387E-92A4-6E1AB74BD4D9> /usr/lib/system/libmacho.dylib
    0x7fff91883000 -     0x7fff9188efff  libsystem_notify.dylib (98.5.0 - compatibility 1.0.0) <C49275CC-835A-3207-AFBA-8C01374927B6> /usr/lib/system/libsystem_notify.dylib
    0x7fff91d1f000 -     0x7fff91d6eff7  libcorecrypto.dylib (??? - ???) <CE0C29A3-C420-339B-ADAA-52F4683233CC> /usr/lib/system/libcorecrypto.dylib
    0x7fff9231e000 -     0x7fff92323fff  libcompiler_rt.dylib (30.0.0 - compatibility 1.0.0) <08F8731D-5961-39F1-AD00-4590321D24A9> /usr/lib/system/libcompiler_rt.dylib
    0x7fff92b21000 -     0x7fff92b3cff7  libsystem_kernel.dylib (2050.18.24 - compatibility 1.0.0) <C0535565-35D1-31A7-A744-63D9F10F12A4> /usr/lib/system/libsystem_kernel.dylib
    0x7fff92c81000 -     0x7fff92c83fff  libquarantine.dylib (52.0.0 - compatibility 1.0.0) <4BE2E642-A14F-340A-B482-5BD2AEFD9C24> /usr/lib/system/libquarantine.dylib
    0x7fff92c84000 -     0x7fff92c8aff7  libunwind.dylib (35.1.0 - compatibility 1.0.0) <21703D36-2DAB-3D8B-8442-EAAB23C060D3> /usr/lib/system/libunwind.dylib
    0x7fff936bb000 -     0x7fff936e9ff7  libsystem_m.dylib (??? - ???) <B434BE5C-25AB-3EBD-BAA7-5304B34E3441> /usr/lib/system/libsystem_m.dylib
    0x7fff93dbd000 -     0x7fff93dbeff7  libSystem.B.dylib (169.3.0 - compatibility 1.0.0) <365477AB-D641-389D-B8F4-A1FAE9657EEE> /usr/lib/libSystem.B.dylib

any help wil be greatly appreciated..

Attachments (1)

main.log (28.0 KB) - added by rahsaan.page@… 7 years ago.
Main.log File for llvm-3.0

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to jeremyhu@…
Port: llvm-3.0 added
Priority: HighNormal
Summary: Executing org.macports.build (llvm-3.0)llvm-3.0 upgrade hangs

Please sudo port clean llvm-3.0 and then try again, and attach the main.log file (whose location is printed by the command port logfile llvm-3.0) if it hangs again. Please let us know what version of Xcode you have and some more info about your Mac model, including processor speed, number of cores, and amount of RAM and free hard disk space. (On some versions of Xcode I've seen the llvm builds take exorbitant amounts of memory (7-8 GB) which takes forever and slows the computer to a crawl if non enough physical memory exists and the hard disk is > 90% full and therefore probably highly fragmented).

Changed 7 years ago by rahsaan.page@…

Attachment: main.log added

Main.log File for llvm-3.0

comment:2 Changed 7 years ago by rahsaan.page@…

Hi Jeremy,

Attached is the main.log file you requested if it hanged again, which it did..

here is the additional details requested:

Xcode Version 4.5.1 (4G1004) Model Name: MacBook Pro

Model Identifier: MacBookPro6,2

Processor Name: Intel Core i7

Processor Speed: 2.66 GHz

Number of Processors: 1

Total Number of Cores: 2

L2 Cache (per Core): 256 KB

L3 Cache: 4 MB

Memory: 8 GB

Processor Interconnect Speed: 4.8 GT/s

Macintosh HD 311.25GB free out of 498.93GB

Thanks for your really appreciate!!

comment:3 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

That main.log file looks truncated.

What exactly is hanging? You have a sample of make in the description, but that's not the problem. It's just waiting on a child process.

You may find the pstree utility helpful:

sudo port -v install pstree
pstree

That should show you the process graph.

comment:4 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: duplicate
Status: newclosed

Closing as likely dupe of #33469 unless more information can be provided.

comment:5 Changed 7 years ago by rahsaan.page@…

here is the output from pstree:

NUJECLIT5AAGZML:~ root# /opt/local/bin/pstree 29423 
-+- 29423 macports /usr/bin/make -j4 -w all
 \-+- 29424 macports /bin/sh -c echo `sw_vers -productVersion`| sed -E 's/(10.[0-9]).*/\1/'
   |-+- 29425 macports /bin/sh -c echo `sw_vers -productVersion`| sed -E 's/(10.[0-9]).*/\1/'
   | \-+- 29427 macports /bin/sh -c echo `sw_vers -productVersion`| sed -E 's/(10.[0-9]).*/\1/'
   |   \--- 29428 macports sw_vers -productVersion
   \--- 29426 macports sed -E s/(10.[0-9]).*/\1/
Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:6 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Ok, you're seeing #34221.

Please take a look at that bug report and provide the information I requested in the last comment. Also, can you provide the full output of 'pstree'?

comment:7 Changed 7 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Note: See TracTickets for help on using tickets.