Opened 8 years ago

Closed 8 years ago

#36774 closed defect (fixed)

Soprano update fails on Lion buildbot

Reported by: mkae (Marko Käning) Owned by: pixilla (Bradley Giesbrecht)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: soprano

Description

I just tried to update soprano and ended up with this:

:info:configure -- Check for working C compiler: /usr/bin/gcc-4.2
:info:configure -- Check for working C compiler: /usr/bin/gcc-4.2 -- broken
:info:configure CMake Error at /opt/macports-test/share/cmake-2.8/Modules/CMakeTestCCompiler.cmake:52 (MESSAGE):
:info:configure   The C compiler "/usr/bin/gcc-4.2" is not able to compile a simple test
:info:configure   program.
:info:configure
:info:configure   It fails with the following output:
:info:configure
:info:configure    Change Dir: /opt/macports-test/var/macports/build/_opt_macports-test_var_macports_sources_rsync.macports.org_release_ports_devel_soprano/soprano/work/build/CMakeFiles/CMakeTmp
:info:configure
:info:configure
:info:configure
:info:configure   Run Build Command:/opt/macports-test/bin/gmake
:info:configure   "cmTryCompileExec4008524440/fast"
:info:configure
:info:configure   /opt/macports-test/bin/gmake -f:info:configure   CMakeFiles/cmTryCompileExec4008524440.dir/build.make:info:configure   CMakeFiles/cmTryCompileExec4008524440.dir/build:info:configure:info:configure   gmake[1]: Entering directory:info:configure   `/opt/macports-test/var/macports/build/_opt_macports-test_var_macports_sources_rsync.macports.org_release_ports_devel_soprano/soprano/work/build/CMakeFiles/CMakeTmp':info:configure:info:configure:info:configure   /opt/macports-test/bin/cmake -E cmake_progress_report:info:configure   /opt/macports-test/var/macports/build/_opt_macports-test_var_macports_sources_rsync.macports.org_release_ports_devel_soprano/soprano/work/build/CMakeFiles/CMakeTmp/CMakeFiles:info:configure   1:info:configure:info:configure   Building C object
:info:configure   CMakeFiles/cmTryCompileExec4008524440.dir/testCCompiler.c.o
:info:configure
:info:configure   /usr/bin/gcc-4.2 -pipe -O2 -arch x86_64 -isysroot /
:info:configure   -mmacosx-version-min=10.6 -o
:info:configure   CMakeFiles/cmTryCompileExec4008524440.dir/testCCompiler.c.o -c
:info:configure   /opt/macports-test/var/macports/build/_opt_macports-test_var_macports_sources_rsync.macports.org_release_ports_devel_soprano/soprano/work/build/CMakeFiles/CMakeTmp/testCCompiler.c
:info:configure
:info:configure
:info:configure   Linking C executable cmTryCompileExec4008524440
:info:configure
:info:configure   /opt/macports-test/bin/cmake -E cmake_link_script
:info:configure   CMakeFiles/cmTryCompileExec4008524440.dir/link.txt --verbose=1
:info:configure
:info:configure   /usr/bin/gcc-4.2 -pipe -O2 -arch x86_64 -isysroot /
:info:configure   -mmacosx-version-min=10.6 -Wl,-search_paths_first
:info:configure   -Wl,-headerpad_max_install_names -lclucene-shared -arch x86_64
:info:configure   CMakeFiles/cmTryCompileExec4008524440.dir/testCCompiler.c.o -o
:info:configure   cmTryCompileExec4008524440
:info:configure
:info:configure   ld: library not found for -lclucene-shared
:info:configure
:info:configure   collect2: ld returned 1 exit status
:info:configure
:info:configure   gmake[1]: Leaving directory
:info:configure   collect2: ld returned 1 exit status:info:configure:info:configure   gmake[1]: Leaving directory:info:configure   `/opt/macports-test/var/macports/build/_opt_macports-test_var_macports_sources_rsync.macports.org_release_ports_devel_soprano/soprano/work/build/CMakeFiles/CMakeTmp':info:configure:info:configure:info:configure   gmake[1]: *** [cmTryCompileExec4008524440] Error 1:info:configure:info:configure   gmake: *** [cmTryCompileExec4008524440/fast] Error 2:info:configure:info:configure:info:configure
:info:configure
:info:configure
:info:configure   CMake will not be able to correctly generate this project.
:info:configure Call Stack (most recent call first):
:info:configure   CMakeLists.txt:1 (project)
:info:configure
:info:configure
:info:configure -- Configuring incomplete, errors occurred!

Change History (12)

comment:1 Changed 8 years ago by mkae (Marko Käning)

Summary: Soprano update fails on Snow LeopardSoprano update fails on both buildbots

comment:2 Changed 8 years ago by mkae (Marko Käning)

Resolution: fixed
Status: newclosed

Fixed, see #36790!

comment:3 Changed 8 years ago by mkae (Marko Käning)

Resolution: fixed
Status: closedreopened

Funnily enough the SL buildbot succeeded, but Lion's failed when trying to build soprano for akonadi: https://build.macports.org/builders/buildports-lion-x86_64/builds/5518

comment:4 Changed 8 years ago by mkae (Marko Käning)

Summary: Soprano update fails on both buildbotsSoprano update fails on Lion buildbot

comment:5 Changed 8 years ago by mkae (Marko Käning)

Trying to avoid clang on Lion (r99265)...

comment:6 Changed 8 years ago by mkae (Marko Käning)

Resolution: fixed
Status: reopenedclosed

Now it also builds fine using gcc on Lion, but there are quite a few (deprecation) warnings...

comment:7 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: closedreopened

This was "fixed" by just blacklisting clang. That's was a workaround a couple years ago, but it's not going to fly much longer. Reopening to actually find a real fix.

comment:8 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

How does this ticket have *ANYTHING* to do with clang? The reported error is with gcc-4.2?

comment:9 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Ok, I see ​https://build.macports.org/builders/buildports-lion-x86_64/builds/5518 is what you're talking about...

Still, this is not the correct fix. There's a bug in the build system, address that rather than blacklisting the compiler.

comment:10 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

The issue is -lclucene-shared ... ld can't find a libclucene-shared to link against.

comment:11 Changed 8 years ago by pixilla (Bradley Giesbrecht)

Sebastian Trüg says: "Soprano clucene module is not required anymore and development has effectively been stopped.".

Adding "-DSOPRANO_DISABLE_CLUCENE_INDEX=1" to soprano should fix this. I will commit when my test build finishes.

Last edited 8 years ago by pixilla (Bradley Giesbrecht) (previous) (diff)

comment:12 Changed 8 years ago by pixilla (Bradley Giesbrecht)

Resolution: fixed
Status: reopenedclosed

r99272 builds Snow Leopard and Lion buildbot servers.

Note: See TracTickets for help on using tickets.