Opened 9 years ago

Closed 9 years ago

#36780 closed defect (fixed)

webkit-gtk 1.10.1_0 fails to build: missing dependency libsoup-2.4 >= 2.39.2

Reported by: ewen-naos-nz (Ewen McNeill) Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: dbevans (David B. Evans)
Port: webkit-gtk

Description

webkit-gtk was just bumped to 1.10.1 by change 99154 (about an hour ago). At least on OS X 10.6 (Snow Leopard) it fails to build with this log message:

[...]
:info:configure checking for LIBSOUP... no
:info:configure configure: error: Package requirements (libsoup-2.4 >= 2.39.2) were not met:
:info:configure 
:info:configure Requested 'libsoup-2.4 >= 2.39.2' but version of libsoup is 2.38.1
:info:configure 
:info:configure Consider adjusting the PKG_CONFIG_PATH environment variable if you
:info:configure installed software in a non-standard prefix.
:info:configure 
:info:configure Alternatively, you may set the environment variables LIBSOUP_CFLAGS
:info:configure and LIBSOUP_LIBS to avoid the need to call pkg-config.
:info:configure See the pkg-config man page for more details.
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_webkit-gtk/webkit-gtk/work/webkitgtk-1.10.1" && ./configure --prefix=/opt/local --with-gtk=2.0 --disable-webkit2 --disable-introspection --enable-link-prefetch --enable-image-resizer --enable-media-statistics --enable-media-stream --enable-svg --enable-geolocation --enable-webgl --enable-page-visibility-api --enable-datagrid --enable-mathml --enable-web-timing --enable-mhtml --enable-microdata --enable-mutation-observers --disable-jit --enable-video-track 
:info:configure Exit code: 1
:error:configure org.macports.configure for port webkit-gtk returned: configure failure: command execution failed

The root cause seems to be that it needs libsoup-2.4 version 2.39.2 or later. MacPorts currently only has libsoup 2.38.1 packaged:

ewen@bethel:~$ port search libsoup
libsoup @2.38.1 (gnome, net)
    Soup is an HTTP library implementation in C.
ewen@bethel:~$

so would both need the new version packaged, and a dependency added to the webkit-gtk port.

Ewen

Change History (3)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: devans@… added
Keywords: libsoup removed
Owner: changed from macports-tickets@… to jeremyhu@…

comment:2 Changed 9 years ago by ingo@…

Exactly the same under Mountain Lion (10.8.2).

comment:3 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: newclosed

Whoops. I forgot to commit that, but someone else did.

Note: See TracTickets for help on using tickets.