Opened 8 years ago

Closed 8 years ago

#36814 closed defect (duplicate)

python27 upgrade : error: unknown type name 'FMetricRec'

Reported by: xl64100@… Owned by: jyrkiwahlstedt
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: python27

Description (last modified by ryandesign (Ryan Schmidt))

Hello,

I can't upgrade my python27 package:

when i run

sudo port clean python27
sudo port upgrade python27

I get the following error while building python27

:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_python27/python27/work/Python-2.7.3/Mac/Modules/fm/_Fmmodule.c:26:11: error: unknown type name 'FMetricRec'
:info:build FMRec_New(FMetricRec *itself)
:info:build           ^
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_python27/python27/work/Python-2.7.3/Mac/Modules/fm/_Fmmodule.c:60:20: error: use of undeclared identifier 'GetFontName'; did you mean 'SGSetFontName'?
:info:build     PyMac_PRECHECK(GetFontName);
:info:build                    ^~~~~~~~~~~
:info:build                    SGSetFontName

Attachments (1)

main.log (1.4 MB) - added by xl64100@… 8 years ago.
python27 building log

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by xl64100@…

Attachment: main.log added

python27 building log

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: python27 FMetricRec removed
Owner: changed from macports-tickets@… to jwa@…

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #36579.

Note: See TracTickets for help on using tickets.