Opened 8 years ago

Closed 8 years ago

#36833 closed defect (fixed)

glabels: error: "Only <glib.h> can be included directly."

Reported by: fabio.zingaro@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: craig.cottingham@…
Port: glabels

Description (last modified by ryandesign (Ryan Schmidt))

Hi all,

I've problems on compiling gLables from ports, in the first step I obtain errors on references in glib libs. (attached main.log.1.txt)

With commands like this:

sudo perl -pi -w -e 's/#include <glib\/gi18n\.h>/#include <glib\.h>/g;' *.h

I substitute all references directly to a file in glib headers to glib.h

In the second step the build process goes forward but it stop for another error. (attached main.log.2.txt)

I've tried to compile with and without the +universal option but it prints the same error on unknown architecture x86_64.

Anyone could help me/us?

Thanks.

Attachments (3)

output1.txt (1.0 KB) - added by fabio.zingaro@… 8 years ago.
main.log.1.txt (283.1 KB) - added by fabio.zingaro@… 8 years ago.
main.log.2.txt (139.3 KB) - added by fabio.zingaro@… 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by fabio.zingaro@…

Attachment: output1.txt added

Changed 8 years ago by fabio.zingaro@…

Attachment: main.log.1.txt added

Changed 8 years ago by fabio.zingaro@…

Attachment: main.log.2.txt added

comment:1 Changed 8 years ago by fabio.zingaro@…

Cc: fabio.zingaro@… added

Cc Me!

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: craig.cottingham@… added; fabio.zingaro@… removed
Description: modified (diff)
Keywords: build process glabels removed
Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned
Summary: gLabels build problemsglabels: error: "Only <glib.h> can be included directly."

comment:3 in reply to:  description Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

Replying to fabio.zingaro@…:

I've problems on compiling gLables from ports, in the first step I obtain errors on references in glib libs. (attached main.log.1.txt)

With commands like this:

sudo perl -pi -w -e 's/#include <glib\/gi18n\.h>/#include <glib\.h>/g;' *.h

I substitute all references directly to a file in glib headers to glib.h

I am able to reproduce the error "Only <glib.h> can be included directly" and have fixed it in the usual way in r99291.

In the second step the build process goes forward but it stop for another error. (attached main.log.2.txt)

I've tried to compile with and without the +universal option but it prints the same error on unknown architecture x86_64.

I'm not able to reproduce this second issue; it builds fine for me after the above fix. The log you attached for the second issue shows it was not a clean build attempt, so please wait 30 minutes, then "sudo port clean glabels" and "sudo port selfupdate" to get my changes from above, then try building again. If it fails again, then file a new ticket for the new problem and attach the new main.log file there. (We should keep it to one issue per ticket.)

Note: See TracTickets for help on using tickets.