Opened 9 years ago

Closed 7 years ago

#36843 closed defect (worksforme)

Fail on install of groovy

Reported by: hdittmer@… Owned by: breun (Nils Breunese)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: iskigow@…
Port: groovy

Description

I have been attempting to install groovy on two different Macs. Both are running Mac OS 10.8.2 and Mac Ports 2.1.2. The attempt to install groovy via "sudo port install groovy" returned "Error: Processing of port groovy failed". A copy of the log file is attached.

Howard

Attachments (1)

main.log (17.2 KB) - added by hdittmer@… 9 years ago.
Log file from machine following failed attempt to install groovy

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by hdittmer@…

Attachment: main.log added

Log file from machine following failed attempt to install groovy

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to breskeby@…
Port: groovy added

comment:2 Changed 8 years ago by ltreugene@…

I found the problem disappeared after I reverted Oracle's JDK-1.7.0_09.jdk back to Apple's JDK 6 on MacOS 10.8.2.

comment:3 Changed 8 years ago by iskigow@…

Cc: iskigow@… added

Cc Me!

comment:4 in reply to:  2 Changed 8 years ago by hdittmer@…

Replying to ltreugene@…:

I found the problem disappeared after I reverted Oracle's JDK-1.7.0_09.jdk back to Apple's JDK 6 on MacOS 10.8.2.

I removed the Oracle JDK and the problem did not go away. I reinstalled the OS (10.8.2) and reinstalled XCODE and the problem remains.

Howard

comment:5 Changed 7 years ago by mf2k (Frank Schima)

Owner: changed from breskeby@… to macports-tickets@…

breskeby has retired. See #44732.

comment:6 Changed 7 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to nils@…

comment:7 Changed 7 years ago by ryandesign (Ryan Schmidt)

The groovy port has been updated to version 2.2.1. Could you please check if this issue persists?

comment:8 Changed 7 years ago by breun (Nils Breunese)

The groovy port uses the binary distribution since r125455. The groovy port no longer builds Groovy from source, so this build issue should no longer occur.

comment:9 Changed 7 years ago by mf2k (Frank Schima)

Resolution: worksforme
Status: newclosed

Sounds good. I'll close the issue.

Note: See TracTickets for help on using tickets.