Opened 8 years ago

Closed 8 years ago

#36852 closed defect (duplicate)

mlt fails to install (during a port upgrade outdated)

Reported by: gregoire.verlut@… Owned by: ddennedy (Dan Dennedy)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: mlt

Description (last modified by mf2k (Frank Schima))

I ran a port upgrade outdated and it fails for mlt.

The log file states:

:info:build consumer_avformat.c:241:18: error: no member named 'encode' in 'struct AVCodec'; did you mean 'encode2'?
:info:build                         if ( ( codec->encode || codec->encode2 ) && codec->type == CODEC_TYPE_AUDIO )
:info:build                                       ^~~~~~
:info:build                                       encode2
:info:build /opt/local/include/libavcodec/avcodec.h:3189:11: note: 'encode2' declared here
:info:build     int (*encode2)(AVCodecContext *avctx, AVPacket *avpkt, const AVFrame *frame,
:info:build           ^
:info:build consumer_avformat.c:265:17: error: no member named 'encode' in 'struct AVCodec'; did you mean 'encode2'?
:info:build                         if ( (codec->encode || codec->encode2) && codec->type == CODEC_TYPE_VIDEO )
:info:build                                      ^~~~~~
:info:build                                      encode2
:info:build /opt/local/include/libavcodec/avcodec.h:3189:11: note: 'encode2' declared here
:info:build     int (*encode2)(AVCodecContext *avctx, AVPacket *avpkt, const AVFrame *frame,
:info:build           ^

Attachments (1)

main.log (1.4 KB) - added by gregoire.verlut@… 8 years ago.
log file for port mlt

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by gregoire.verlut@…

Attachment: main.log added

log file for port mlt

comment:1 Changed 8 years ago by mf2k (Frank Schima)

Description: modified (diff)
Keywords: mlt removed
Owner: changed from macports-tickets@… to dan@…
Port: mlt added

In the future, please use WikiFormatting, fill in the Port field and Cc the port maintainer(s).

That's not the right main.log that you attached. clean the port and try again and post the new log for mlt if it fails.

comment:2 Changed 8 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: newclosed

This a duplicate of #36817. Please search before filing new tickets.

Note: See TracTickets for help on using tickets.