Opened 9 years ago

Closed 9 years ago

#36900 closed defect (duplicate)

perl5.12 5.12.4_1 failed to install

Reported by: ashleynoelhinton@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: perl5.12

Description

Attempting to install wine using 'port install wine'

Returns following error

Error: org.macports.build for port perl5.12 returned: command execution failed
Error: Failed to install perl5.12
Please see the log file for port perl5.12 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_perl5.12/perl5.12/main.log

Tried 'port clean perl5.12' and 'port install perl5.12' which appeared to be successful, but still getting the same error when attempting to install wine.

Have attached log file.

Attachments (1)

main.log (119.4 KB) - added by ashleynoelhinton@… 9 years ago.
Error log

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by ashleynoelhinton@…

Attachment: main.log added

Error log

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Port: perl5.12 added
Resolution: duplicate
Status: newclosed

The log shows this error:

:info:build ld: in /opt/local/lib/libstdc++.6.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /opt/local/lib/libstdc++.6.dylib for architecture i386
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)

Duplicate of #36438.

Note: See TracTickets for help on using tickets.