Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#36926 closed defect (fixed)

cairo @1.12.8 build failure when xorg-libXext is not installed

Reported by: david@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: cairo

Description

Hi, i'm trying to install kdelibs4 which fails due to an error in cairo. When installing cairo i get an error in "xrender.h";

Logfiles: https://dl.dropbox.com/u/72498/pastes/main.log and https://dl.dropbox.com/u/72498/pastes/config.log

Attachments (2)

main.log (839.6 KB) - added by david@… 10 years ago.
config.log (182.6 KB) - added by david@… 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by david@…

Attachment: main.log added

Changed 10 years ago by david@…

Attachment: config.log added

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… removed
Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned
Summary: cairo @1.12.8 build failurecairo @1.12.8 build failure when xorg-libXext is not installed

Thanks, both buildbots ran into this problem too and I couldn't figure out what it was and couldn't reproduce it on my systems. It felt like a missing dependency and I knew I needed to look at the config.log but we can't access the buildbot's files. Your config.log makes it clear:

configure:22163: checking for XRenderCreateLinearGradient
configure:22163: /usr/bin/clang -o conftest -pipe -O2 -arch x86_64   -I/opt/local/include -I/opt/local/include    -I/opt/local/include -L/opt/local/lib -arch x86_64 conftest.c      -L/opt/local/lib -lX11 -lXext  -L/opt/local/lib -lXrender -lX11    >&5
ld: library not found for -lXext
clang: error: linker command failed with exit code 1 (use -v to see invocation)

We're missing a library dependency on xorg-libXext.

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

comment:3 Changed 10 years ago by ryandesign (Ryan Schmidt)

Has duplicate #36928.

comment:4 Changed 10 years ago by ryandesign (Ryan Schmidt)

Has duplicate #36937.

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

To receive this fix, as with every other MacPorts fix, run "sudo port selfupdate". For good measure, also run "sudo port clean cairo". Then try installing or updating cairo again.

Note: See TracTickets for help on using tickets.