Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#36928 closed defect (duplicate)

cairo: error: redefinition of '_XLinearGradient'

Reported by: liut12@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: cairo

Description (last modified by ryandesign (Ryan Schmidt))

mini01s-Mac-mini:~ admin$ sudo port install wireshark
Password:
--->  Computing dependencies for wireshark
--->  Dependencies to be installed: gtk2 atk gobject-introspection cairo gdk-pixbuf2 jasper jpeg tiff hicolor-icon-theme pango Xft2 shared-mime-info intltool gnome-common p5.12-getopt-long p5.12-pathtools p5.12-scalar-list-utils p5.12-xml-parser xorg-libXcomposite xorg-compositeproto xorg-libXext xorg-util-macros xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto kerberos5 libgeoip libpcap libsmi lua portaudio
--->  Building cairo
Error: org.macports.build for port cairo returned: command execution failed
Error: Failed to install cairo
Please see the log file for port cairo for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_cairo/cairo/main.log
Error: The following dependencies were not installed: gtk2 atk gobject-introspection cairo gdk-pixbuf2 jasper jpeg tiff hicolor-icon-theme pango Xft2 shared-mime-info intltool gnome-common p5.12-getopt-long p5.12-pathtools p5.12-scalar-list-utils p5.12-xml-parser xorg-libXcomposite xorg-compositeproto xorg-libXext xorg-util-macros xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto kerberos5 libgeoip libpcap libsmi lua portaudio
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port wireshark failed

Attachments (1)

main.log (17.1 KB) - added by liut12@… 8 years ago.
cairo error log

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by liut12@…

Attachment: main.log added

cairo error log

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: wireshark port removed
Owner: changed from macports-tickets@… to ryandesign@…
Port: cairo added
Priority: HighNormal
Summary: Failed to port install wiresharkcairo: error: redefinition of '_XLinearGradient'

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Duplicate of #36926.

comment:3 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

comment:4 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: reopenedclosed

comment:5 in reply to:  4 Changed 8 years ago by liut12@…

Replying to ryandesign@…: Thx! good to know it is fixed. when will the fix be available?

comment:6 Changed 8 years ago by ryandesign (Ryan Schmidt)

It is already available. As usual, run "sudo port clean cairo", then "sudo port selfupdate", then try again.

comment:7 in reply to:  6 Changed 8 years ago by liut12@…

Replying to ryandesign@…:

It is already available. As usual, run "sudo port clean cairo", then "sudo port selfupdate", then try again.

WOW! It works now! It is amazing not only because it has been fixed, but also your response time is quickest & spontaneously efficient. THANK YOU!

comment:8 Changed 8 years ago by ryandesign (Ryan Schmidt)

Glad to help!

Note: See TracTickets for help on using tickets.