New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #36940 (closed defect: duplicate)

Opened 18 months ago

Last modified 16 months ago

PovRay not installing... Apparently thread-local storage unsupported

Reported by: jumasoal@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: macosx12345@…
Port: povray

Description (last modified by ryandesign@…) (diff)

Hi all! I have been trying to upgrade povray, but I can not find why is not possible. I also uninstalled the previous version, but the installation also fails. Any help is quite appreciated.

The first line in which I can see an error is this:

:info:build ../../source/backend/support/task.h:187: error: thread-local storage not supported for this target

This is what shows up in the log file:

:notice:build --->  Building povray
:debug:build Executing org.macports.build (povray)
:debug:build Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_povray/povray/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6'
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_povray/povray/work/povray-3.7.0.RC6" && /usr/bin/make -j2 -w all'
:debug:build Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_povray/povray/work/povray-3.7.0.RC6" && /usr/bin/make -j2 -w all 
:info:build make: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_povray/povray/work/povray-3.7.0.RC6'
:info:build /usr/bin/make  all-recursive
:info:build make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_povray/povray/work/povray-3.7.0.RC6'
:info:build Making all in source
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_povray/povray/work/povray-3.7.0.RC6/source'
:info:build Making all in backend
:info:build make[3]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_povray/povray/work/povray-3.7.0.RC6/source/backend'
:info:build /usr/bin/g++-4.2 -DHAVE_CONFIG_H -I. -I../..  -I../.. -I../../source -I../../source -I../../source/base -I../../unix -I../../vfe -I../../vfe/unix -I/opt/local/include/SDL -D_GNU_SOURCE=1 -D_THREAD_SAFE -D_THREAD_SAFE -I/opt/local/include/OpenEXR   -I/opt/local/../include -I/opt/local/../include -I/opt/local/../include -I/opt/local/../include -I/opt/local/include -pthread -I/opt/local/include  -I/usr/include  -pipe -Wno-multichar -Wno-write-strings -fno-enforce-eh-specs -s -O3 -ffast-math -pipe -O2 -arch x86_64 -D_THREAD_SAFE -MT boundingtask.o -MD -MP -MF .deps/boundingtask.Tpo -c -o boundingtask.o `test -f 'bounding/boundingtask.cpp' || echo './'`bounding/boundingtask.cpp
:info:build /usr/bin/g++-4.2 -DHAVE_CONFIG_H -I. -I../..  -I../.. -I../../source -I../../source -I../../source/base -I../../unix -I../../vfe -I../../vfe/unix -I/opt/local/include/SDL -D_GNU_SOURCE=1 -D_THREAD_SAFE -D_THREAD_SAFE -I/opt/local/include/OpenEXR   -I/opt/local/../include -I/opt/local/../include -I/opt/local/../include -I/opt/local/../include -I/opt/local/include -pthread -I/opt/local/include  -I/usr/include  -pipe -Wno-multichar -Wno-write-strings -fno-enforce-eh-specs -s -O3 -ffast-math -pipe -O2 -arch x86_64 -D_THREAD_SAFE -MT bbox.o -MD -MP -MF .deps/bbox.Tpo -c -o bbox.o `test -f 'bounding/bbox.cpp' || echo './'`bounding/bbox.cpp
:info:build In file included from ../../source/backend/scene/threaddata.h:101,
:info:build                  from bounding/bbox.cpp:107:
:info:build ../../source/backend/support/task.h:187: error: thread-local storage not supported for this target
:info:build In file included from ../../source/backend/support/taskqueue.h:100,
:info:build                  from ../../source/backend/scene/view.h:101,
:info:build                  from ../../source/backend/bounding/boundingtask.h:102,
:info:build                  from bounding/boundingtask.cpp:102:
:info:build ../../source/backend/support/task.h:187: error: thread-local storage not supported for this target
:info:build make[3]: *** [bbox.o] Error 1
:info:build make[3]: *** Waiting for unfinished jobs....
:info:build make[3]: *** [boundingtask.o] Error 1
:info:build make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_povray/povray/work/povray-3.7.0.RC6/source/backend'
:info:build make[2]: *** [all-recursive] Error 1
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_povray/povray/work/povray-3.7.0.RC6/source'
:info:build make[1]: *** [all-recursive] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_povray/povray/work/povray-3.7.0.RC6'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_povray/povray/work/povray-3.7.0.RC6'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_povray/povray/work/povray-3.7.0.RC6" && /usr/bin/make -j2 -w all 
:info:build Exit code: 2
:error:build org.macports.build for port povray returned: command execution failed
:debug:build Error code: CHILDSTATUS 18887 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: targets not executed for povray: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Please see the log file for port povray for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_povray/povray/main.log

Attachments

Portfile.diff (386 bytes) - added by macosx12345@… 16 months ago.
Proposal of a patch to the Portfile to allow compilation under Mac OS 10.6
patch-vfe-unix-syspovconfig.h (628 bytes) - added by macosx12345@… 16 months ago.
Proposal of a patch to allow compilation under Mac OS 10.6

Change History

comment:1 follow-up: ↓ 2 Changed 18 months ago by ryandesign@…

  • Status changed from new to closed
  • Keywords povray removed
  • Resolution set to duplicate
  • Port set to povray
  • Description modified (diff)

Remember to use WikiFormatting when writing in Trac and to fill in the Port field.

Duplicate of #36172.

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 17 months ago by jumasoal@…

Replying to ryandesign@…:

Remember to use WikiFormatting when writing in Trac and to fill in the Port field.

Duplicate of #36172.

Thanks, I am new, I'll do that for the next post =) Finally after your comment and more surfing, I have installed povray. The original post for fixing is this:

http://news.povray.org/povray.beta-test/thread/%3Cweb.4d091fcd62af24a47800993b0%40news.povray.org%3E/?mtop=363443&moff=10

This is what one has to do (borrowed from the above link):

In vfe/unix/syspovconfig.h remove lines 174-177 (#defines regarding THREAD_LOCAL_PTR)

In vfe/unix/vfeplatform.h add #include <sys/types.h> before #include <boost/shared_ptr.hpp>

In vfe/vfesession.h add #include <sys/types.h> before #include <queue>

In source/base/image/image.cpp replace all occurrences of lseek64 with lseek

Actually only the first action is needed in the current port. The others I didn't do them. I do not really know how the performance of povray is affected, but it compiles. I made the changes by hand since I don't know how to implement patches to the ports. If anyone can do this, would be great.

Thanks!

Last edited 17 months ago by jumasoal@… (previous) (diff)

Changed 16 months ago by macosx12345@…

Proposal of a patch to the Portfile to allow compilation under Mac OS 10.6

Changed 16 months ago by macosx12345@…

Proposal of a patch to allow compilation under Mac OS 10.6

comment:3 in reply to: ↑ 2 Changed 16 months ago by macosx12345@…

Replying to jumasoal@…:

Actually only the first action is needed in the current port. The others I didn't do them. I do not really know how the performance of povray is affected, but it compiles. I made the changes by hand since I don't know how to implement patches to the ports. If anyone can do this, would be great.

Thanks! I attached to this ticket a patch to perform the first action and the corresponding modification to the Portfile. This is probably just a quick and dirty solution (see #36172) but at least the port compiles under Mac OS 10.6 without further change.

comment:4 Changed 16 months ago by macosx12345@…

  • Cc macosx12345@… added

Cc Me!

Note: See TracTickets for help on using tickets.