Opened 10 years ago

Closed 10 years ago

#36982 closed defect (fixed)

PLPlot fails fortran compiler test, doesn't enable fortran support

Reported by: chrisonian@… Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: plplot

Description (last modified by ryandesign (Ryan Schmidt))

I have been trying to install plplot with f77 support, and think the problem is early in the CMake build checking the gfortran compiler. Note that the compiler works fine in other CMake projects, and by itself. Here is the verbose output:

sudo port -v install plplot +gcc45
--->  Computing dependencies for plplot.
--->  Fetching archive for plplot
--->  plplot-5.9.9_4+aquaterm+gcc45.darwin_12.x86_64.tbz2 doesn't seem to exist in /opt/local/var/macports/incoming/verified
--->  Attempting to fetch plplot-5.9.9_4+aquaterm+gcc45.darwin_12.x86_64.tbz2 from http://lil.fr.packages.macports.org/plplot
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
--->  Attempting to fetch plplot-5.9.9_4+aquaterm+gcc45.darwin_12.x86_64.tbz2 from http://packages.macports.org/plplot
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
--->  Attempting to fetch plplot-5.9.9_4+aquaterm+gcc45.darwin_12.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/plplot
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
--->  Fetching distfiles for plplot
--->  Verifying checksum(s) for plplot
--->  Checksumming plplot-5.9.9.tar.gz
--->  Extracting plplot
--->  Extracting plplot-5.9.9.tar.gz
--->  Configuring plplot
-- The C compiler identification is Clang 4.0.0
-- Check for working C compiler: /usr/bin/clang
-- Check for working C compiler: /usr/bin/clang -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- CMake version = 2.8.9
-- SH_EXECUTABLE = /bin/bash
-- Checking whether system has ANSI C header files
-- Looking for 4 include files stdlib.h, ..., float.h
-- Looking for 4 include files stdlib.h, ..., float.h - found
-- Performing Test memchrExists
-- Performing Test memchrExists - Success
-- Performing Test freeExists
-- Performing Test freeExists - Success
-- Check for whether ctype.h macros work on characters with the
   high bit set.
-- High-bit characters - work
-- ANSI C header files - found
-- Looking for include file unistd.h
-- Looking for include file unistd.h - found
-- Looking for include file termios.h
-- Looking for include file termios.h - found
-- Looking for include file stdint.h
-- Looking for include file stdint.h - found
-- Looking for crt_externs.h
-- Looking for crt_externs.h - found
-- Performing Test HAVE_SYS_WAIT_H
-- Performing Test HAVE_SYS_WAIT_H - Success
-- Looking for DIR in sys/types.h;dirent.h
-- Looking for DIR in sys/types.h;dirent.h - found
-- Check for signal return type in <signal.h>
-- Check for signal handler return type type void  - found
-- Looking for popen
-- Looking for popen - found
-- Looking for usleep
-- Looking for usleep - found
-- Looking for mkstemp
-- Looking for mkstemp - found
-- Looking for mkstemp
-- Looking for mkstemp - found
-- Looking for _NSGetArgc
-- Looking for _NSGetArgc - found
-- Looking for finite
-- Looking for finite - found
-- Looking for isnan
-- Looking for isnan - found
-- Looking for isinf
-- Looking for isinf - found
-- Looking for snprintf
-- Looking for snprintf - found
-- SWIG_VERSION = 2.0.8
-- Found Perl: /opt/local/bin/perl (found version "5.12.4") 
-- Looking for pkg-config - found
-- Looking for XOpenDisplay in /opt/local/lib/libX11.dylib;/opt/local/lib/libXext.dylib
-- Looking for XOpenDisplay in /opt/local/lib/libX11.dylib;/opt/local/lib/libXext.dylib - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /opt/local/lib/libX11.dylib
-- X11_FOUND = 1
-- X11_INCLUDE_DIR = /opt/local/include;/usr/X11R6/include
-- X11_COMPILE_FLAGS = -I/opt/local/include -I/usr/X11R6/include
-- X11_LIBRARIES = /opt/local/lib/libSM.dylib;/opt/local/lib/libICE.dylib;/opt/local/lib/libX11.dylib;/opt/local/lib/libXext.dylib
-- The C compiler identification is Clang 4.0.0
-- Check for working C compiler: /usr/bin/clang
-- Check for working C compiler: /usr/bin/clang -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- CMAKE_GENERATOR = Unix Makefiles
-- The CXX compiler identification is Clang 4.0.0
-- Check for working CXX compiler: /usr/bin/clang++
-- Check for working CXX compiler: /usr/bin/clang++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Configuring done
-- Generating done
-- Build files have been written to: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_plplot/plplot/work/build/language_tests/CXX
-- The CXX compiler identification is Clang 4.0.0
-- Check for working CXX compiler: /usr/bin/clang++
-- Check for working CXX compiler: /usr/bin/clang++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for using namespace support
-- Check for using namespace - found
-- Looking for C++ include cmath
-- Looking for C++ include cmath - found
-- Check for broken isnan support in <cmath>
-- Check for isnan in <cmath> - found
-- Check for using stdint.h with CXX compiler
-- Check for using stdint.h with CXX compiler - ok
-- The C compiler identification is Clang 4.0.0
-- Check for working C compiler: /usr/bin/clang
-- Check for working C compiler: /usr/bin/clang -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- CMAKE_GENERATOR = Unix Makefiles
-- The Fortran compiler identification is GNU
-- Check for working Fortran compiler: /opt/local/bin/gfortran
-- Check for working Fortran compiler: /opt/local/bin/gfortran  -- broken
CMake Error at /opt/local/share/cmake-2.8/Modules/CMakeTestFortranCompiler.cmake:40 (MESSAGE):
  The Fortran compiler "/opt/local/bin/gfortran" is not able to compile a
  simple test program.

  It fails with the following output:

   Change Dir: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_plplot/plplot/work/build/language_tests/Fortran/CMakeFiles/CMakeTmp

  

  Run Build Command:/opt/local/bin/gmake "cmTryCompileExec842144888/fast"

  /opt/local/bin/gmake -f CMakeFiles/cmTryCompileExec842144888.dir/build.make
  CMakeFiles/cmTryCompileExec842144888.dir/build

  gmake[1]: Entering directory
  `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_plplot/plplot/work/build/language_tests/Fortran/CMakeFiles/CMakeTmp'


  /opt/local/bin/cmake -E cmake_progress_report
  /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_plplot/plplot/work/build/language_tests/Fortran/CMakeFiles/CMakeTmp/CMakeFiles
  1

  Building Fortran object
  CMakeFiles/cmTryCompileExec842144888.dir/testFortranCompiler.f.o

  /opt/local/bin/gfortran -pipe -O2 -m64 -c
  /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_plplot/plplot/work/build/language_tests/Fortran/CMakeFiles/CMakeTmp/testFortranCompiler.f
  -o CMakeFiles/cmTryCompileExec842144888.dir/testFortranCompiler.f.o

  Linking Fortran executable cmTryCompileExec842144888

  /opt/local/bin/cmake -E cmake_link_script
  CMakeFiles/cmTryCompileExec842144888.dir/link.txt --verbose=1

  /opt/local/bin/gfortran -L/opt/local/lib -arch x86_64 -pipe -O2 -m64
  CMakeFiles/cmTryCompileExec842144888.dir/testFortranCompiler.f.o -o
  cmTryCompileExec842144888

  gfortran: error: x86_64: No such file or directory

  gfortran: error: unrecognized option '-arch'

  gmake[1]: *** [cmTryCompileExec842144888] Error 1

  gmake[1]: Leaving directory
  `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_plplot/plplot/work/build/language_tests/Fortran/CMakeFiles/CMakeTmp'


  gmake: *** [cmTryCompileExec842144888/fast] Error 2

  

  

  CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
  CMakeLists.txt:19 (enable_language)


-- Configuring incomplete, errors occurred!
-- WARNING: no working Fortran compiler so disabling Fortran bindings and examples.
-- Looking for include paths and libraries for Tcl/Tk
-- Found Tclsh: /opt/local/bin/tclsh (found version "8.5") 
-- Found TCL: /opt/local/lib/libtcl.dylib  
-- Found TCLTK: /opt/local/lib/libtcl.dylib  
-- Found TK: /opt/local/lib/libtk.dylib  
-- Looking for include paths and libraries for Tcl/Tk - found
-- Looking for tclsh
-- Looking for tclsh - found
-- TCL_TCLSH = /opt/local/bin/tclsh
-- TCL_INCLUDE_PATH = /opt/local/include
-- TCL_LIBRARY = /opt/local/lib/libtcl.dylib
-- TK_INCLUDE_PATH = /opt/local/include;/opt/local/include;/usr/X11R6/include
-- TK_LIBRARY = /opt/local/lib/libtk.dylib;/opt/local/lib/libSM.dylib;/opt/local/lib/libICE.dylib;/opt/local/lib/libX11.dylib;/opt/local/lib/libXext.dylib
-- FREETYPE_INCLUDE_DIR = /opt/local/include/freetype2
-- FREETYPE_LIBRARIES = /opt/local/lib/libfreetype.dylib
-- Check for NaN awareness in C compiler
-- Check for NaN awareness in C compiler - found
-- FindQHull: Found both qhull_a.h and libqhull.a
-- Looking for qh_new_qhull
-- Looking for qh_new_qhull - found
-- QHULL_INCLUDE_DIRS = /opt/local/include
-- QHULL_LIBRARIES = /opt/local/lib/libqhull.dylib
-- QHULL_RPATH = /opt/local/lib
-- checking for module 'pango'
--   found pango, version 1.30.1
-- checking for module 'pangoft2'
--   found pangoft2, version 1.30.1
-- Looking for dlopen in dl
-- Looking for dlopen in dl - found
-- Found LTDL: /opt/local/lib/libltdl.dylib;/usr/lib/libdl.dylib
-- LTDL_INCLUDE_DIR = /opt/local/include
-- LTDL_LIBRARY_DIR = /opt/local/lib
-- LTDL_LIBRARIES = /opt/local/lib/libltdl.dylib;/usr/lib/libdl.dylib
-- checking for module 'pangocairo'
--   found pangocairo, version 1.30.1
-- Not a Windows platform so setting wincairo driver to OFF.
-- checking for modules 'lasi;pango;pangoft2'
--   found lasi, version 1.1.0
--   found pango, version 1.30.1
--   found pangoft2, version 1.30.1
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - not found.
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - found
-- Looking for QT_MAC_USE_COCOA
-- Looking for QT_MAC_USE_COCOA - found
-- Found Qt4: /opt/local/bin/qmake (found version "4.8.3") 
-- Found AQT: /opt/local/Library/Frameworks/AquaTerm.framework
-- WARNING: validate target will not be available to check for syntax issues in the PLplot DocBook documentation because onsgmls was not found.
-- WARNING: Perl modules XML::Parser and/or XML::DOM not available
   so cannot check that swig_documentation.i is up to date.

Summary of CMake build system results for PLplot

Install location variables which can be set by the user:
CMAKE_INSTALL_PREFIX:      /opt/local
CMAKE_INSTALL_EXEC_PREFIX  /opt/local
CMAKE_INSTALL_BINDIR 	   /opt/local/bin
CMAKE_INSTALL_DATADIR 	   /opt/local/share
CMAKE_INSTALL_LIBDIR 	   /opt/local/lib
CMAKE_INSTALL_INCLUDEDIR   /opt/local/include
CMAKE_INSTALL_INFODIR 	   /opt/local/share/info
CMAKE_INSTALL_MANDIR 	   /opt/local/share/man

Derived install location variables:
DATA_DIR	/opt/local/share/plplot5.9.9
LIB_DIR		/opt/local/lib
INCLUDE_DIR	/opt/local/include/plplot
BIN_DIR		/opt/local/bin
TCL_DIR		/opt/local/share/plplot5.9.9/tcl
ADA_INCLUDE_DIR	/opt/local/share/ada/adainclude/plplotadad
ADA_LIB_DIR	/opt/local/lib/ada/adalib/plplotadad
PYTHON_INSTDIR	
DRV_DIR		/opt/local/lib/plplot5.9.9/driversd
DOC_DIR		/opt/local/share/doc/plplot
MAN_DIR		/opt/local/share/man
INFO_DIR	/opt/local/share/info

Other important CMake variables:

CMAKE_SYSTEM_NAME:	Darwin
UNIX:			1
WIN32:			
APPLE:			1
MSVC:				(MSVC_VERSION:	)
MINGW:			
MSYS:			
CYGWIN:			
BORLAND:		
WATCOM:		  

SWIG_FOUND:		1
PERL_FOUND:		TRUE
X11_FOUND:		1

CMAKE_BUILD_TYPE:	
CMAKE_C_COMPILER CMAKE_C_FLAGS:			/usr/bin/clang -I/opt/local/include -I/opt/local/include
CMAKE_CXX_COMPILER CMAKE_CXX_FLAGS:		/usr/bin/clang++ -I/opt/local/include -O2
LIB_TAG:		d

ENABLE_DYNDRIVERS:	ON
DRIVERS_LIST: aqt;cairo;qt;mem;null;ps;psttf;svg;tk;xfig;xwin
DEVICES_LIST: aqt;memcairo;extcairo;pdfcairo;pngcairo;pscairo;svgcairo;xcairo;epsqt;pdfqt;qtwidget;bmpqt;jpgqt;pngqt;ppmqt;tiffqt;extqt;memqt;svgqt;mem;null;ps;psttf;svg;tk;xfig;xwin

Library options:
BUILD_SHARED_LIBS:	ON		PL_DOUBLE:	ON

Optional libraries:
PL_HAVE_QHULL:		ON		WITH_CSA:	ON
HAVE_FREETYPE:		ON		PL_HAVE_PTHREAD:	OFF
HAVE_AGG:		OFF

Language Bindings:
ENABLE_f77:		OFF		ENABLE_f95:		OFF
ENABLE_cxx:		ON		ENABLE_java:		OFF
ENABLE_python:		OFF		ENABLE_octave:		OFF
ENABLE_tcl:		ON		ENABLE_itcl:		OFF
ENABLE_tk:		ON		ENABLE_itk:		OFF
ENABLE_pdl:		OFF		ENABLE_wxwidgets:	OFF
ENABLE_ada:		OFF		ENABLE_d:		OFF
ENABLE_ocaml:		OFF		ENABLE_lua:		OFF
ENABLE_qt:		OFF		ENABLE_pyqt4:		OFF

-- Configuring done
-- Generating done
CMake Warning:
  Manually-specified variables were not used by the project:

    CMAKE_Fortran_COMPILER
    CMAKE_Fortran_FLAGS
    TCL_STUB_LIBRARY
    TK_STUB_LIBRARY


-- Build files have been written to: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_plplot/plplot/work/build
--->  Building plplot

Change History (4)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: chrisonian@… removed
Description: modified (diff)
Keywords: fortran removed
Owner: changed from macports-tickets@… to takeshi@…

What port provided /opt/local/bin/gfortran? The presence of that seems to be causing some trouble.

port provides /opt/local/bin/gfortran

comment:2 in reply to:  1 Changed 10 years ago by chrisonian@…

Replying to ryandesign@…:

What port provided /opt/local/bin/gfortran? The presence of that seems to be causing some trouble.

Ah, it was pointing to mp-gcc46. I switched back to mp-gcc45 with 'port select gcc' and now it compiles fine.

However, I really just need this to work with gcc 4.6. Is it possible to add this variant?

comment:3 Changed 10 years ago by ryandesign (Ryan Schmidt)

Agreed, gcc46 and gcc47 variants should be added.

comment:4 Changed 10 years ago by tenomoto (Takeshi Enomoto)

Resolution: fixed
Status: newclosed

Committed in r100757.

Note: See TracTickets for help on using tickets.