Opened 5 years ago

Closed 5 years ago

#37029 closed defect (fixed)

add active_variants/require_active_variants to pymol

Reported by: howarth@… Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: haspatch maintainer Cc:
Port: pymol

Description

The pymol package requires the base package for tcl (with CoreFoundation support disabled)
and the x11 variant of tk for proper operation. The attached Portfile.diff adds the active_variants
PortGroup to the pymol Portfile and uses require_active_variants entries for tcl and tk to set these
requirements.

Attachments (1)

Portfile.diff (1.2 KB) - added by howarth@… 5 years ago.
use require_active_variants for tcl and tk

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by howarth@…

use require_active_variants for tcl and tk

comment:1 Changed 5 years ago by neverpanic (Clemens Lang)

  • Keywords haspatch maintainer added
  • Owner changed from macports-tickets@… to cal@…
  • Status changed from new to assigned

comment:2 Changed 5 years ago by neverpanic (Clemens Lang)

  • Resolution set to fixed
  • Status changed from assigned to closed

Commited the active_variants change in r99794 and the update in r99795.

Note that lint generates a warning:

:) clemens@cSchlepptop:/opt/dports/science/pymol$ port lint
--->  Verifying Portfile for pymol
Warning: no license set
--->  0 errors and 1 warnings found.

The LICENSE file seems to be a BSD license; if that's correct you can indicate that using license BSD in the Portfile to silence this warning.

In the future, feel free to tag bugs with maintainer for your ports and haspatch when you attach a patch.

Note: See TracTickets for help on using tickets.