Opened 10 years ago

Closed 5 years ago

#37093 closed defect (fixed)

port log gets written to different port's logfile

Reported by: ryandesign (Ryan Schmidt) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 2.1.99
Keywords: Cc: brandon.zacharie@…, larryv (Lawrence Velázquez)
Port:

Description

This has happened to me often enough that I have to report it now.

Sometimes when installing a port, and dependencies get installed first, the information logged in the requested port's logfile is information about one of the dependencies.

It doesn't happen when just asking to install a single port. Unfortunately I cannot say how to reproduce it.

For example, in the plplot port's directory, I issued "sudo port install" in a MacPorts installation without too many ports already installed. I got this:

$ sudo port install
--->  Computing dependencies for libLASi
--->  Fetching distfiles for libLASi
--->  Verifying checksum(s) for libLASi
--->  Extracting libLASi
--->  Configuring libLASi
--->  Building libLASi
--->  Staging libLASi into destroot
--->  Installing libLASi @1.1.1_0
--->  Cleaning libLASi
--->  Computing dependencies for libLASi
--->  Deactivating libLASi @1.1.0_0
--->  Cleaning libLASi
--->  Activating libLASi @1.1.1_0
--->  Cleaning libLASi
--->  Computing dependencies for plplot
--->  Dependencies to be installed: aquaterm freefont-ttf qhull swig-tcl bison gsed swig pcre tcl
--->  Fetching distfiles for aquaterm
--->  Verifying checksum(s) for aquaterm
--->  Extracting aquaterm
--->  Configuring aquaterm
--->  Building aquaterm
--->  Staging aquaterm into destroot
--->  Installing aquaterm @1.1.1_0
--->  Activating aquaterm @1.1.1_0
--->  Cleaning aquaterm
--->  Fetching distfiles for freefont-ttf
--->  Verifying checksum(s) for freefont-ttf
--->  Extracting freefont-ttf
--->  Configuring freefont-ttf
--->  Building freefont-ttf
--->  Staging freefont-ttf into destroot
--->  Installing freefont-ttf @20060126_1
--->  Activating freefont-ttf @20060126_1
--->  Cleaning freefont-ttf
--->  Fetching distfiles for qhull
--->  Verifying checksum(s) for qhull
--->  Extracting qhull
--->  Applying patches to qhull
--->  Configuring qhull
--->  Building qhull
--->  Staging qhull into destroot
--->  Installing qhull @2012.1_2
--->  Activating qhull @2012.1_2
--->  Cleaning qhull
--->  Fetching distfiles for bison
--->  Verifying checksum(s) for bison
--->  Extracting bison
--->  Configuring bison
--->  Building bison
--->  Staging bison into destroot
--->  Installing bison @2.6.5_0
--->  Activating bison @2.6.5_0
--->  Cleaning bison
--->  Fetching distfiles for gsed
--->  Verifying checksum(s) for gsed
--->  Extracting gsed
--->  Configuring gsed
--->  Building gsed
--->  Staging gsed into destroot
--->  Installing gsed @4.2.1_2
--->  Activating gsed @4.2.1_2
--->  Cleaning gsed
--->  Fetching distfiles for pcre
--->  Verifying checksum(s) for pcre
--->  Extracting pcre
--->  Configuring pcre
--->  Building pcre
--->  Staging pcre into destroot
--->  Installing pcre @8.31_0
--->  Activating pcre @8.31_0
--->  Cleaning pcre
--->  Fetching distfiles for swig
--->  Verifying checksum(s) for swig
--->  Extracting swig
--->  Configuring swig
--->  Building swig
--->  Staging swig into destroot
--->  Installing swig @2.0.8_2
--->  Activating swig @2.0.8_2
--->  Cleaning swig
--->  Fetching distfiles for tcl
--->  Verifying checksum(s) for tcl
--->  Extracting tcl
--->  Configuring tcl
--->  Building tcl
--->  Staging tcl into destroot
--->  Installing tcl @8.5.13_0+corefoundation
--->  Activating tcl @8.5.13_0+corefoundation
--->  Cleaning tcl
--->  Fetching distfiles for swig-tcl
--->  Verifying checksum(s) for swig-tcl
--->  Extracting swig-tcl
--->  Configuring swig-tcl
--->  Building swig-tcl
--->  Staging swig-tcl into destroot
--->  Installing swig-tcl @2.0.8_2
--->  Activating swig-tcl @2.0.8_2
--->  Cleaning swig-tcl
--->  Fetching distfiles for plplot
--->  Verifying checksum(s) for plplot
--->  Extracting plplot
--->  Configuring plplot
--->  Building plplot
Error: org.macports.build for port plplot returned: command execution failed
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port plplot failed

Curious to know why the build failed, I checked port log plplot, but in fact it printed the log of the successful build of libLASi.

I also wonder why did libLASi get installed before these lines were printed:

--->  Computing dependencies for plplot
--->  Dependencies to be installed: aquaterm freefont-ttf qhull swig-tcl bison gsed swig pcre tcl

What was special about libLASi that got it installed before that?

Also, why did the above output not include the following lines:

Please see the log file for port plplot for details:
    /opt/local/var/macports/logs/_Users_rschmidt_macports_dports_science_plplot/plplot/main.log

I suspect these various symptoms are related somehow.

I am running a somewhat recent revision of trunk here, but I have noticed the omission of these lines in some user bug reports too, so I think the problem exists in the released 2.1.2 version as well.

Change History (8)

comment:1 Changed 9 years ago by brandon.zacharie@…

Cc: brandon.zacharie@… added

Cc Me!

comment:2 in reply to:  description Changed 9 years ago by jmroot (Joshua Root)

Replying to ryandesign@…:

I also wonder why did libLASi get installed before these lines were printed:

--->  Computing dependencies for plplot
--->  Dependencies to be installed: aquaterm freefont-ttf qhull swig-tcl bison gsed swig pcre tcl

What was special about libLASi that got it installed before that?

It was already installed but outdated.

comment:3 Changed 9 years ago by ci42

Cc: ciserlohn@… added

Cc Me!

comment:4 Changed 9 years ago by ci42

Cc: ciserlohn@… removed

Cc Me!

comment:5 Changed 8 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… added

Cc Me!

comment:6 Changed 7 years ago by jmroot (Joshua Root)

Any improvement after r140540?

comment:7 Changed 7 years ago by ryandesign (Ryan Schmidt)

I haven't deliberately tried to cause this problem, but I don't think I've seen it since then.

comment:8 Changed 5 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

Fixed then, I guess?

Note: See TracTickets for help on using tickets.