Opened 8 years ago

Closed 6 years ago

#37110 closed defect (fixed)

ShiftIt 1.5.1: fatal error: 'X11/Xlib.h' file not found

Reported by: John-Whitlock@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: hubsif, otto.julio@…, kurthindenburg (Kurt Hindenburg)
Port: shiftit

Description

ShiftIt build fails on X11Utils.c because it can't find the header X11/Xlib.h. Build log attached.

Attachments (1)

main.log (51.3 KB) - added by John-Whitlock@… 8 years ago.
Build log for ShiftIt 1.5.1 on 10.8 Mountain Lion

Download all attachments as: .zip

Change History (12)

Changed 8 years ago by John-Whitlock@…

Attachment: main.log added

Build log for ShiftIt 1.5.1 on 10.8 Mountain Lion

comment:1 Changed 8 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to phw@…

Please remember to Cc the maintainer.

comment:2 Changed 7 years ago by hubsif

Cc: hubsif@… added

Cc Me!

comment:3 Changed 6 years ago by otto.julio@…

Cc: otto.julio@… added

Cc Me!

comment:4 Changed 6 years ago by ryandesign (Ryan Schmidt)

Summary: ShiftIt 1.5.1 fails to build on 10.8 Mountain LionShiftIt 1.5.1: fatal error: 'X11/Xlib.h' file not found

Has duplicate #43106.

comment:5 Changed 6 years ago by petrrr

phw retired, #45339.

comment:6 Changed 6 years ago by petrrr

Owner: changed from phw@… to macports-tickets@…

comment:7 Changed 6 years ago by kurthindenburg (Kurt Hindenburg)

Cc: khindenburg@… added

Cc Me!

comment:8 Changed 6 years ago by kurthindenburg (Kurt Hindenburg)

try updating your ports and see if 1.6 works for you

comment:9 Changed 6 years ago by John-Whitlock@…

I'm sorry, I've moved on to Yosemite and Homebrew - can anyone else test?

comment:10 Changed 6 years ago by otto.julio@…

I installed it on OS X Yosemite (10.10.1) and it is correctly working now! Thanks!

comment:11 Changed 6 years ago by kurthindenburg (Kurt Hindenburg)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.