Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#37289 closed defect (invalid)

wget: perl version 5.16.1 can't run /usr/bin/pod2man

Reported by: etler@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: wget

Description

Trying to install wget on OS X 10.6.8, 1.83 GHz Intel Core Duo MacBook Pro. All of the dependencies install just fine but wget gives me:

--->  Computing dependencies for wget
--->  Fetching archive for wget
--->  Attempting to fetch wget-1.14_0+ssl.darwin_10.i386.tbz2 from http://packages.macports.org/wget
--->  Attempting to fetch wget-1.14_0+ssl.darwin_10.i386.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/wget
--->  Attempting to fetch wget-1.14_0+ssl.darwin_10.i386.tbz2 from http://lil.fr.packages.macports.org/wget
--->  Fetching distfiles for wget
--->  Verifying checksum(s) for wget
--->  Extracting wget
--->  Applying patches to wget
--->  Configuring wget
--->  Building wget
Error: org.macports.build for port wget returned: command execution failed
Please see the log file for port wget for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_wget/wget/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port wget failed

I uninstalled every dependency and reinstalled with no luck.

Xcode version is:

Xcode 3.2.6
Component versions: DevToolsCore-1809.0; DevToolsSupport-1806.0
BuildVersion: 10M2518

Here are my currently installed ports:

The following ports are currently installed:
  expat @2.1.0_0 (active)
  gdbm @1.10_2 (active)
  gettext @0.18.1.1_2 (active)
  gnutls @2.12.19_0 (active)
  gperf @3.0.4_2 (active)
  libgcrypt @1.5.0_0 (active)
  libgpg-error @1.10_0 (active)
  libiconv @1.14_0 (active)
  libidn @1.25_0 (active)
  libtasn1 @2.11_0 (active)
  lzo2 @2.05_1 (active)
  ncurses @5.9_1 (active)
  perl5.16 @5.16.1_1 (active)
  pkgconfig @0.27.1_1 (active)
  readline @6.2.000_0 (active)
  xz @5.0.4_0 (active)

Attachments (1)

main.log (173.8 KB) - added by etler@… 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by etler@…

Attachment: main.log added

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Summary: wget @1.14_0 +ssl org.macports.build command execution failedwget: perl version 5.16.1 can't run /usr/bin/pod2man

The relevant error in the log seems to be "perl version 5.16.1 can't run /usr/bin/pod2man." Try installing "perl5 +perl5_12", then cleaning wget and trying again.

comment:2 Changed 6 years ago by etler@…

That seems to have fixed it. I thought that might be the issue so I reverted to perl 5.8.9 and that also failed. Then I saw your update and installed perl 5.12.4 and it worked. Seems sort of unfortunate that you have to have a specific version of perl to install wget and it's unclear from the logs which version is needed.

comment:3 Changed 6 years ago by etler@…

I should also add a thank you here. This really made my day much easier.

comment:4 Changed 6 years ago by ryandesign (Ryan Schmidt)

Thanks for confirming that worked. I'm still confused why it failed for you though. The log shows:

:info:configure checking for perl... /usr/bin/perl
:info:configure checking for pod2man... /usr/bin/pod2man

Also, the first line of /usr/bin/pod2man on my system reads:

#!/usr/bin/perl

Which means that the system version of pod2man should have used the system version of perl with which it should have worked.

The only explanation I can think of is that you replaced the system's /usr/bin/perl with a symlink to or a copy of perl 5.16... Is that what happened?

comment:5 Changed 6 years ago by etler@…

Ah yeah I did do that. Right now I have:

lrwxr-xr-x     1 root   wheel          23 Dec 12 10:00 perl -> /opt/local/bin/perl5.12

I'm guessing maybe that's not the right way to do that?

comment:6 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed

Yes, that would be the cause. Please restore /usr/bin/perl to the way it should be. You shouldn't change system files like /usr/bin/perl which could have consequences for the operating system; also your changes might be undone by future OS updates.

Instead, install the perl5 port with the perl5_16 variant. ("sudo port install perl5 +perl5_16") This will give you the symlink /opt/local/bin/perl pointing to /opt/local/bin/perl5.16.

Perl in MacPorts is somewhat unusual in this mechanism. The preferred mechanism these days is "port select", but perl in MacPorts predates that mechanism and has not been updated for it yet.

Some small number of ports might fail with perl symlinked to perl5.16 in this way. perl5.12 is still the default in MacPorts so most of us don't test with anything else. If you encounter such a problem just reactivate perl5+5_12 for the duration of the build.

comment:7 Changed 6 years ago by etler@…

Got it! Thanks for the explanation. I felt sort of dirty when I did that initially but I couldn't figure out a better way at the time. Much appreciated.

Note: See TracTickets for help on using tickets.