Opened 6 years ago

Closed 6 years ago

#37307 closed defect (worksforme)

kdepimlibs4 4.9.3 CMake Error unset variables NEPOMUK_LIBRARIES-NOTFOUND

Reported by: sneeuwitje@… Owned by: sharky@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: NicosPavlov
Port: kdepimlibs4

Description

I'm a bit confused upgrading ports v1.x to v2.1.2. After double selfupdate and some errors that miraculously solved themselves after installing libiconv, I'm stuck upgrading kdepimlibs4 from v4.6.0 to v4.9.3

the bottleneck seems to ly in unset variable NEPOMUK_LIBRARIES:

:info:configure -----------------------------------------------------------------------------
:info:configure -- Congratulations! All external packages have been found.
:info:configure -----------------------------------------------------------------------------
:info:configure 
:info:configure CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
:info:configure Please set them or make sure they are set and tested correctly in the CMake files:
:info:configure NEPOMUK_LIBRARIES (ADVANCED)
:info:configure     linked by target "akonadi-contact" in directory /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepimlibs4/kdepimlibs4/work/kdepimlibs-4.9.3/akonadi/contact
:info:configure     linked by target "akonadi-calendar" in directory /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepimlibs4/kdepimlibs4/work/kdepimlibs-4.9.3/akonadi/calendar
:info:configure 
:info:configure -- Configuring incomplete, errors occurred!

See main.log attached for details. akonadi-contact and -calendar targets are there, but what's with CMake Error?

Can anybody help me fix this?

Attachments (1)

kdepimlibs4-main.log (4.3 MB) - added by sneeuwitje@… 6 years ago.
main.log

Change History (11)

Changed 6 years ago by sneeuwitje@…

Attachment: kdepimlibs4-main.log added

main.log

comment:1 Changed 6 years ago by sneeuwitje@…

Cc: sneeuwitje@… added

Cc Me!

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: nicos@… added; sneeuwitje@… removed
Keywords: kdepimlibs4 nepomuk libraries notfound anokadi-contact anokadi-calendar removed
Owner: changed from macports-tickets@… to sharky@…
Type: requestdefect

Try installing the nepomuk-core port?

comment:3 Changed 6 years ago by NicosPavlov

The error message would indeed point to a missing nepomuk-core, even though for what I had tested it was not needed to build kdepimlibs4. It could be worth looking if the following solves the issue:

sudo port install nepomuk-core
sudo port clean kdepimlibs4
sudo port install kdepimlibs4

comment:4 in reply to:  3 Changed 6 years ago by sneeuwitje@…

Replying to nicos@…:

The error message would indeed point to a missing nepomuk-core, even though for what I had tested it was not needed to build kdepimlibs4. It could be worth looking if the following solves the issue:

sudo port install nepomuk-core
sudo port clean kdepimlibs4
sudo port install kdepimlibs4

Installing nepomuk-core seemed the sensible thing, but did not work for me (OSX 10.7). Log-line 36255 indicates missing libsoprano:

36255    :info:configure -- Found Nepomuk: NEPOMUK_LIBRARIES-NOTFOUND;/opt/local/lib/libsoprano.dylib

but that can't be true since the file exists on my machine and soprano is installed through ports in /opt/local/ ::baffled::

comment:5 Changed 6 years ago by NicosPavlov

This output may be helpful anyway. The correct line should be:

-- Found Nepomuk: /opt/local/lib/libnepomuk.dylib;/opt/local/lib/libsoprano.dylib 

Do you have /opt/local/lib/libnepomuk.dylib on your system, which should be provided by kdelibs4 ? If not, it means that a problem occurred at installation of kdelibs4. There are some requirements so that kdelibs build nepomuk library, and at configure stage of kdelibs, the following lines should appear:

   * Soprano - Support for the Nepomuk semantic desktop system
   * Soprano Raptor Parser - Support for the Nepomuk semantic desktop system
   * Soprano Redland Backend - Support for the Nepomuk semantic desktop system
   * Shared desktop ontologies - Support for the Nepomuk semantic desktop system

If not, there is an issue with the dependencies.

comment:6 Changed 6 years ago by sneeuwitje@…

Ah, that of course doesn't happen for me... it just breaks. So this should be fixed in kdelibs4 port-release?

Is there a way to get around this with custom build-parameters and then do port activate ...? I can handle a bit of building, but it mustn't get too complicated :-/

If any of you all need other info, let me know.

Last edited 6 years ago by sneeuwitje@… (previous) (diff)

comment:7 Changed 6 years ago by NicosPavlov

So, if I follow correctly, kdelibs4 breaks too ?

Just to be sure, do you have all the latest ports (sudo port selfupdate and then sudo port upgrade outdated) ? The latest shared-desktop-ontologies (version 0.10.0) is required for example in order to build correctly the latest kdelibs4.

Then, if it still breaks with all ports at latest versions, the main.log when building kdelibs4 would be helpful, in order to know where and how it breaks. Since I can't reproduce this issue even when using the same compiler, it is not easy to guess.

comment:8 in reply to:  7 Changed 6 years ago by sneeuwitje@…

Replying to nicos@…:

So, if I follow correctly, kdelibs4 breaks too ?

Thanks. Correct. I'm stuck in upgrade outdated at kdepimlibs4 after multiple selfupdate. Please see initial post for details. Main.log is already attached.

Or am I missing something?

Not sure about desktop-ontologies. Om à train rightnow. Won't be on my machine untill late tomorrow.

Last edited 6 years ago by sneeuwitje@… (previous) (diff)

comment:9 in reply to:  5 Changed 6 years ago by ak.ml@…

Replying to nicos@…:

This output may be helpful anyway. The correct line should be:

-- Found Nepomuk: /opt/local/lib/libnepomuk.dylib;/opt/local/lib/libsoprano.dylib 

Do you have /opt/local/lib/libnepomuk.dylib on your system, which should be provided by kdelibs4 ?

Thanks nicos! For some reason /opt/local/lib/libnepomuk.dylib was not in kdelibs4.
Recompiling kdelibs4 solved the issue.

comment:10 Changed 6 years ago by NicosPavlov

Resolution: worksforme
Status: newclosed

Good. I would assume that kdelibs4 was built before some requirements were upgraded, but it is not really possible to know that.

Note: See TracTickets for help on using tickets.