Opened 8 years ago

Closed 5 years ago

Last modified 5 years ago

#37343 closed enhancement (fixed)

nmap: add a "-subversion" variant

Reported by: irony42@… Owned by: opendarwin.org@…
Priority: Low Milestone:
Component: ports Version:
Keywords: Cc: danielluke (Daniel J. Luke), ryandesign (Ryan Schmidt), dogcow@…, wyuenho (Jimmy Yuen Ho Wong)
Port: nmap

Description

nmap builds fine without subversion, albeit without an "nmap-update" feature. It would be nice to be able to forgo this dependency via a variant.

Attachments (3)

37343.patch (563 bytes) - added by wyuenho (Jimmy Yuen Ho Wong) 5 years ago.
This patch removes subversion dep in the default build and added a variant for that
patch2.patch (963 bytes) - added by irony42@… 5 years ago.
A patch that also works in the -subversion case
nmap.7.10_1.patch (1.6 KB) - added by wyuenho (Jimmy Yuen Ho Wong) 5 years ago.
Macport style hints for editor, revision and force default installation without subversion

Download all attachments as: .zip

Change History (18)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: dluke@… added
Owner: changed from macports-tickets@… to opendarwin.org@…
Port: nmap added
Summary: add a "-subversion" variant to nmapnmap: add a "-subversion" variant
Type: requestenhancement
Version: 2.1.2

comment:2 Changed 8 years ago by danielluke (Daniel J. Luke)

When I first looked at this, there didn't appear to be a clean way to build without subversion (but that has possibly changed with subsequent upstream releases).

If this is something you really want, it will happen faster if you can submit a patch :-)

comment:3 Changed 8 years ago by larryv (Lawrence Velázquez)

Cc: larry.velazquez@… added

Cc Me!

comment:4 Changed 8 years ago by ryandesign (Ryan Schmidt)

I was working on a patch; I'll add it tomorrow.

comment:5 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Cc Me!

comment:6 Changed 8 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… added; larry.velazquez@… removed

comment:7 Changed 8 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… removed

Cc Me!

comment:8 Changed 7 years ago by dogcow@…

Cc: dogcow@… added

Cc Me!

Changed 5 years ago by wyuenho (Jimmy Yuen Ho Wong)

Attachment: 37343.patch added

This patch removes subversion dep in the default build and added a variant for that

comment:9 Changed 5 years ago by danielluke (Daniel J. Luke)

Thanks for the patch, but I don't think it actually works in the -subversion case (if subversion is installed, it will still get used). There needs to be something that forces the build to not use subversion if the variant isn't selected (so that builds are reproducible).

Changed 5 years ago by irony42@…

Attachment: patch2.patch added

A patch that also works in the -subversion case

Changed 5 years ago by wyuenho (Jimmy Yuen Ho Wong)

Attachment: nmap.7.10_1.patch added

Macport style hints for editor, revision and force default installation without subversion

comment:10 Changed 5 years ago by wyuenho (Jimmy Yuen Ho Wong)

Cc: wyuenho@… added

Cc Me!

comment:11 Changed 5 years ago by danielluke (Daniel J. Luke)

Resolution: fixed
Status: newclosed

I went ahead and added +subversion as a default variant and converted the no_* variants to match the style. (r147186)

comment:12 Changed 5 years ago by wyuenho (Jimmy Yuen Ho Wong)

Why would anybody want to use the subversion variant as default? The whole point of this ticket was to get rid of it as a default dependency. nmap-update is an old closed-alpha project.

https://twitter.com/bonsaiviking/status/710561647765499904

comment:13 in reply to:  12 ; Changed 5 years ago by danielluke (Daniel J. Luke)

Replying to wyuenho@…:

Why would anybody want to use the subversion variant as default?

maybe ask upstream why it's in the default ./configure ?

The whole point of this ticket was to get rid of it as a default dependency. nmap-update is an old closed-alpha project.

You can easily build without it now, you couldn't before.

comment:14 in reply to:  13 ; Changed 5 years ago by wyuenho (Jimmy Yuen Ho Wong)

Replying to dluke@…:

Replying to wyuenho@…:

Why would anybody want to use the subversion variant as default?

maybe ask upstream why it's in the default ./configure ?

That configure script also builds with ndiff, zenmap and nping, the same question could also be asked why they aren't in the requirements of this port. I think for me, I just want a default nmap package that I'd expect on a Linux distro. AFAIK, both CentOS and Ubuntu package nmap with lua by default. r147186 not only got rid of lua as a dep and not providing a variant for it, but also reenabled subversion as a default variant. I'm not sure what the reasoning for this change is. BTW, this Portfile violates Macport's coding standard. nmap has also gone on to 7.12 now.

The whole point of this ticket was to get rid of it as a default dependency. nmap-update is an old closed-alpha project.

You can easily build without it now, you couldn't before.

But that shouldn't be the default, and certainly not what this ticket was asking for.

Last edited 5 years ago by wyuenho (Jimmy Yuen Ho Wong) (previous) (diff)

comment:15 in reply to:  14 Changed 5 years ago by danielluke (Daniel J. Luke)

Replying to wyuenho@…:

That configure script also builds with ndiff, zenmap and nping,

zenmap/ndiff isn't built by default because of the large dependency tree (and maintainer discretion - see also #24177)

r147186 not only got rid of lua as a dep

nope it didn't change it (still builds with --with-liblua=included)

and not providing a variant for it, but also reenabled subversion as a default variant.

nope, it moved subversion to a default variant from being unconditionally required.

BTW, this Portfile violates Macport's coding standard.

Maintainers have a wide latitude for Portfile style.

nmap has also gone on to 7.12 now.

yes, it was released yesterday. I plan on updating it when I get some time.

The bug tracker is not really the place to have this conversation. If you'd like to continue, I'd suggest we move to macports-dev.

Note: See TracTickets for help on using tickets.