Opened 6 years ago

Closed 6 years ago

#37376 closed defect (fixed)

Moving to tcltk 8.6 breaks other ports

Reported by: ralph@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: mww@…, adfernandes (Andrew Fernandes), g5pw (Aljaž Srebrnič), nonstop.server@…, macports-trac@…, cooljeanius (Eric Gallager), sears3@…, dshean@…, manuel.deljesuspe@…
Port: wordnet grass vtk5 tcl tk

Description (last modified by ryandesign (Ryan Schmidt))

The following ports failed to rebuild after updating to tcltk 8.6.0

  • wordnet
  • grass
  • vtk5

Attachments (3)

error.log (608 bytes) - added by ralph@… 6 years ago.
error log for building grass
main.log.zip (180.5 KB) - added by ralph@… 6 years ago.
Error log for building grass
grass.patch (1.5 KB) - added by g5pw (Aljaž Srebrnič) 6 years ago.

Download all attachments as: .zip

Change History (30)

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Cc: mww@… adfernandes@… g5pw@… added
Port: wordnet, grass, vtk5, tcl, tkwordnet grass vtk5 tcl tk

comment:2 Changed 6 years ago by nonstop.server@…

Cc: nonstop.server@… added

Cc Me!

comment:3 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)

comment:4 Changed 6 years ago by macports-trac@…

Cc: macports-trac@… added

Cc Me!

comment:5 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:6 Changed 6 years ago by g5pw (Aljaž Srebrnič)

The main problem seems to be here:

:info:configure checking for Tcl configuration... found /usr/lib/tclConfig.sh
:info:configure checking for Tk configuration... found /usr/lib/tkConfig.sh
:info:configure checking for existence of /usr/lib/tclConfig.sh... loading
:info:configure checking for existence of /usr/lib/tkConfig.sh... loading

The configure script picks up the system tcl and not the macports one. I'll try to patch the configure script to get the macports one first!

comment:7 Changed 6 years ago by g5pw (Aljaž Srebrnič)

wordnet fixed in r100783.

comment:8 Changed 6 years ago by g5pw (Aljaž Srebrnič)

I can't seem to find an error for grass, although the build errors out. Can someone provide a failed build log?

comment:9 in reply to:  7 Changed 6 years ago by ralph@…

Replying to g5pw@…:

wordnet fixed in r100783.

Confirmed the fix works.

comment:10 in reply to:  8 Changed 6 years ago by ralph@…

Replying to g5pw@…:

I can't seem to find an error for grass, although the build errors out. Can someone provide a failed build log?

Please see later message for attached log.

Last edited 6 years ago by ralph@… (previous) (diff)

Changed 6 years ago by ralph@…

Attachment: error.log added

error log for building grass

Changed 6 years ago by ralph@…

Attachment: main.log.zip added

Error log for building grass

comment:11 Changed 6 years ago by g5pw (Aljaž Srebrnič)

vtk5 fixed in r100787.

comment:12 Changed 6 years ago by g5pw (Aljaž Srebrnič)

ok, the error for grass is this one:

Undefined symbols for architecture x86_64:
  "_TkCopyAndGlobalEval", referenced from:
      _CancelFunc_Hook in draw.o

comment:13 in reply to:  11 ; Changed 6 years ago by adfernandes (Andrew Fernandes)

Replying to g5pw@…:

vtk5 fixed in r100787.

Wow - thanks for tracking this down; wasn't looking forward to it... :-)

comment:14 in reply to:  13 Changed 6 years ago by g5pw (Aljaž Srebrnič)

Replying to adfernandes@…:

Replying to g5pw@…:

vtk5 fixed in r100787.

Wow - thanks for tracking this down; wasn't looking forward to it... :-)

You're very welcome! I always try to fix my mistakes... ;)

Changed 6 years ago by g5pw (Aljaž Srebrnič)

Attachment: grass.patch added

comment:15 Changed 6 years ago by g5pw (Aljaž Srebrnič)

The attached patch attempts to fix the grass compilation by re-adding a private API function that was deleted in tk 8.6. I have still failures in two directories though, lib/python and gui/wxpython. The first is due to a space/tab mixed indent leading to an error, and the second one is a syntax error:

  File "/opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org_trunk_dports_gis_grass/grass/work/grass-6.4.2/dist.i386-apple-darwin12.2.0/etc/wxpython/compat/subprocess.py", line 679
    if (GetVersion() >= 0x80000000L or
                                  ^
SyntaxError: invalid syntax

I guess the port is not using a specified python version, but just the currently selected one (mine is python33)

comment:16 Changed 6 years ago by cooljeanius (Eric Gallager)

I think tcl-sqlite3 was broken by this version change...

DEBUG: couldn't read file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_databases_tcl-sqlite3/tcl-sqlite3/work/destroot/opt/local/lib/tcl8.5/sqlite3/pkgIndex.tcl": no such file or directory
    while executing
"exec /usr/bin/sed s|3.6|3.6.22|g < /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_databases_t..."
    ("eval" body line 1)
    invoked from within
"eval exec $cmdline"
Error: reinplace: couldn't read file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_databases_tcl-sqlite3/tcl-sqlite3/work/destroot/opt/local/lib/tcl8.5/sqlite3/pkgIndex.tcl": no such file or directory
Error: org.macports.destroot for port tcl-sqlite3 returned: reinplace sed(1) failed
DEBUG: Error code: NONE
DEBUG: Backtrace: reinplace sed(1) failed
    while executing
"$post $targetname"
Warning: targets not executed for tcl-sqlite3: org.macports.activate org.macports.destroot org.macports.install

It's still trying to check the tcl8.5 lib directory...

comment:17 in reply to:  16 Changed 6 years ago by larryv (Lawrence Velázquez)

Replying to egall@…:

I think tcl-sqlite3 was broken by this version change...

#37932.

comment:18 Changed 6 years ago by g5pw (Aljaž Srebrnič)

Fixed tcl-sqlite3 in r102708. Now, to recap, which ports still fail to build? Has anyone tried my patch for grass?

comment:19 Changed 6 years ago by ralph@…

Not too sure how to apply the patch, and you said other things were still broken, so I'm afraid I didn't try the grass patch yet.

comment:20 Changed 6 years ago by sears3@…

Cc: sears3@… added

Cc Me!

comment:21 Changed 6 years ago by dshean@…

Cc: dshean@… added

Cc Me!

comment:22 in reply to:  18 ; Changed 6 years ago by vaccari@…

Replying to g5pw@…:

Fixed tcl-sqlite3 in r102708. Now, to recap, which ports still fail to build? Has anyone tried my patch for grass?

I just tried the patch and succeeded building grass +postgresql91. Thanks for that!

When I launch grass though, I'm still getting an error that prevents me at using the GUI:

Starting GRASS ...
ERROR: wxGUI requires wxPython. No module named wxversion
Error in GUI startup. If necessary, please
report this error to the GRASS developers.
Switching to text mode now.

Is this a problem in the port, or should I really ask the grass developers? I see http://trac.macports.org/ticket/36904 is there already...

Last edited 6 years ago by vaccari@… (previous) (diff)

comment:23 in reply to:  22 ; Changed 6 years ago by g5pw (Aljaž Srebrnič)

Replying to vaccari@…:

Is this a problem in the port, or should I really ask the grass developers? I see http://trac.macports.org/ticket/36904 is there already...

I really don't know, we should wait for the grass maintainer to respond to the ticket...

BTW: I see from your email address that you study/work at the Uni in Trieste, I'm a student there! Small world :)

comment:24 in reply to:  23 Changed 6 years ago by vaccari@…

Replying to g5pw@…:

Replying to vaccari@…:

Is this a problem in the port, or should I really ask the grass developers? I see http://trac.macports.org/ticket/36904 is there already...

I really don't know, we should wait for the grass maintainer to respond to the ticket...

Eh, nomaintainer there... I wish I could help...

BTW: I see from your email address that you study/work at the Uni in Trieste, I'm a student there! Small world :)

'ssai picio indeed... ;-)

comment:25 Changed 6 years ago by manuel.deljesuspe@…

Cc: manuel.deljesuspe@… added

Cc Me!

comment:26 Changed 6 years ago by g5pw (Aljaž Srebrnič)

I can finally close this, as grass should be fixed in r106731. Sorry for the delay, I was actually stumped by a side effect of #36904.

comment:27 Changed 6 years ago by g5pw (Aljaž Srebrnič)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.