Opened 6 years ago

Closed 4 years ago

#37434 closed defect (fixed)

HandBrake compile fails with automake 1.13: possibly undefined macro: AM_CONFIG_HEADER

Reported by: garyrobertdavidson@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: ryandesign (Ryan Schmidt), martinezino@…, whcordis@…, cooljeanius (Eric Gallager), jere@…, zeael@…, macports@…, mathsmac@…
Port: HandBrake

Description

Cant seem to find any useful errors in the log.

Error: org.macports.build for port HandBrake returned: command execution failed
Please see the log file for port HandBrake for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_HandBrake/HandBrake/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port handbrake failed

last lines of log

:info:build License: GPL version 2 or later
:info:build Creating config.mak and config.h...
:info:build touch contrib/ffmpeg/.stamp.configure
:info:build Showing first 200 notices only
:info:build 
:info:build 
:info:build ** BUILD FAILED **
:info:build 
:info:build 
:info:build The following build commands failed:
:info:build 	ExternalBuildToolExecution external
:info:build (1 failure)
:info:build make: *** [macosx.build] Error 65
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_HandBrake/HandBrake/work/HandBrake-0.9.8/build'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_HandBrake/HandBrake/work/HandBrake-0.9.8/build" && /usr/bin/make -j4 -w 
:info:build Exit code: 2
:error:build org.macports.build for port HandBrake returned: command execution failed
:debug:build Error code: CHILDSTATUS 42933 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: targets not executed for HandBrake: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Please see the log file for port HandBrake for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_HandBrake/HandBrake/main.log

What I have tried (just to be sure)

sudo port install libiconv
sudo port install libtool
sudo port install autoconf
sudo port install automake
uname -r
11.4.2

Thx in advance..

Attachments (2)

main.log (163.2 KB) - added by garyrobertdavidson@… 6 years ago.
HandBrake Compile log
main.2.log (1.9 MB) - added by garyrobertdavidson@… 6 years ago.
automake 1.12.6_0 compile

Change History (17)

Changed 6 years ago by garyrobertdavidson@…

Attachment: main.log added

HandBrake Compile log

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Cc: garyrobertdavidson@… removed

The reporter is automatically Cc'ed.

This looks like another problem caused by the new version of automake.

comment:2 Changed 6 years ago by garyrobertdavidson@…

Which version should I be using.. (sorry I mean which version does not have the problem)

Last edited 6 years ago by garyrobertdavidson@… (previous) (diff)

comment:3 Changed 6 years ago by garyrobertdavidson@…

bash-4.2# port installed automake
The following ports are currently installed:
  automake @1.11.3_0
  automake @1.11.4_0
  automake @1.12_0
  automake @1.12.3_0
  automake @1.12.6_0
  automake @1.13_0 (active)
bash-4.2# port activate automake @1.12.6_0
--->  Computing dependencies for automake
--->  Deactivating automake @1.13_0
--->  Cleaning automake
--->  Activating automake @1.12.6_0
--->  Cleaning automake
bash-4.2# port install HandBrake
--->  Computing dependencies for HandBrake
--->  Building HandBrake
Error: org.macports.build for port HandBrake returned: command execution failed
Please see the log file for port HandBrake for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_HandBrake/HandBrake/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port HandBrake failed
bash-4.2#

comment:4 Changed 6 years ago by garyrobertdavidson@…

oops sorry forgot to "clean"

Last edited 6 years ago by garyrobertdavidson@… (previous) (diff)

comment:5 Changed 6 years ago by garyrobertdavidson@…

With version 1.12.6_0 version of automake I get a different error

:info:build     /usr/bin/clang++ -arch x86_64 -L/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_HandBrake/HandBrake/work/HandBrake-0.9.8/build/xroot -L/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_HandBrake/HandBrake/work/HandBrake-0.9.8/build/libhb -L/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_HandBrake/HandBrake/work/HandBrake-0.9.8/build/contrib/lib -F/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_HandBrake/HandBrake/work/HandBrake-0.9.8/build/xroot -filelist /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_HandBrake/HandBrake/work/HandBrake-0.9.8/build/xroot/HandBrakeCLI.build/Objects-normal/x86_64/HandBrakeCLI.LinkFileList -mmacosx-version-min=10.7 -framework AudioToolbox -framework IOKit -framework CoreServices -liconv -lbz2 -lz -lhb -la52 -lass -lavcodec -lavformat -lavutil -lbluray -ldca -ldvdnav -ldvdread -lfaac -lfontconfig -lfreetype -lfribidi -lmkv -lmp3lame -lmp4v2 -lmpeg2 -logg -lsamplerate -lswscale -ltheora -lvorbis -lvorbisenc -lx264 -lxml2 -o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_HandBrake/HandBrake/work/HandBrake-0.9.8/build/xroot/HandBrakeCLI
:info:build Undefined symbols for architecture x86_64:
:info:build   "_libiconv_close", referenced from:
:info:build       _decsrtClose in libhb.a(decsrtsub.o)
:info:build       _FcSfntNameTranscode in libfontconfig.a(fcfreetype.o)
:info:build       _xmlFindCharEncodingHandler in libxml2.a(encoding.o)
:info:build       _xmlCharEncCloseFunc in libxml2.a(encoding.o)
:info:build   "_libiconv", referenced from:
:info:build       _decsrtWork in libhb.a(decsrtsub.o)
:info:build       _FcSfntNameTranscode in libfontconfig.a(fcfreetype.o)
:info:build       _xmlIconvWrapper in libxml2.a(encoding.o)
:info:build   "_libiconv_open", referenced from:
:info:build       _decsrtInit in libhb.a(decsrtsub.o)
:info:build       _FcSfntNameTranscode in libfontconfig.a(fcfreetype.o)
:info:build       _xmlFindCharEncodingHandler in libxml2.a(encoding.o)
:info:build ld: symbol(s) not found for architecture x86_64
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
file /usr/lib/libiconv*
/usr/lib/libiconv.2.4.0.dylib: Mach-O universal binary with 2 architectures
/usr/lib/libiconv.2.4.0.dylib (for architecture x86_64):	Mach-O 64-bit dynamically linked shared library x86_64
/usr/lib/libiconv.2.4.0.dylib (for architecture i386):	Mach-O dynamically linked shared library i386
/usr/lib/libiconv.2.dylib:     Mach-O universal binary with 2 architectures
/usr/lib/libiconv.2.dylib (for architecture x86_64):	Mach-O 64-bit dynamically linked shared library x86_64
/usr/lib/libiconv.2.dylib (for architecture i386):	Mach-O dynamically linked shared library i386
/usr/lib/libiconv.dylib:       Mach-O universal binary with 2 architectures
/usr/lib/libiconv.dylib (for architecture x86_64):	Mach-O 64-bit dynamically linked shared library x86_64
/usr/lib/libiconv.dylib (for architecture i386):	Mach-O dynamically linked shared library i386

Changed 6 years ago by garyrobertdavidson@…

Attachment: main.2.log added

automake 1.12.6_0 compile

comment:6 Changed 6 years ago by garyrobertdavidson@…

Updating XCode (not sure which version I had) to the 4.5.2 version, (and reinstalling the command line tools) fixed the problem with automake 1.12.6_0.

Newer automake 1.13_0 version still wont compile however.

consider fix to be

port activate automake @1.12.6_0

comment:7 in reply to:  1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Summary: HandBrake compile FailsHandBrake compile fails with automake 1.13: possibly undefined macro: AM_CONFIG_HEADER

Replying to macsforever2000@…:

This looks like another problem caused by the new version of automake.

Yes, the error in the log is:

:info:build configure.in:9: error: possibly undefined macro: AM_CONFIG_HEADER
:info:build       If this token and others are legitimate, please use m4_pattern_allow.
:info:build       See the Autoconf documentation.

The automake 1.13 release notes confirm that AM_CONFIG_HEADER, which has been superseded by AC_CONFIG_HEADERS for ten years, has finally been removed.

Replying to garyrobertdavidson@…:

With version 1.12.6_0 version of automake I get a different error

That's #36667.

Replying to garyrobertdavidson@…:

Updating XCode (not sure which version I had) to the 4.5.2 version, (and reinstalling the command line tools) fixed the problem with automake 1.12.6_0.

Interesting. I've added that information to #36667. Maybe we need to blacklist some older clang versions for HandBrake.

Newer automake 1.13_0 version still wont compile however.

consider fix to be

port activate automake @1.12.6_0

That's a workaround, not a fix.

comment:8 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: martinezino@… added

comment:ticket:36298:4 is a duplicate.

comment:9 Changed 6 years ago by whcordis@…

Cc: whcordis@… added

Cc Me!

comment:10 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: egall@… added

Has duplicate #37855.

comment:11 Changed 6 years ago by jere@…

Cc: jere@… added

Cc Me!

comment:12 Changed 6 years ago by larryv (Lawrence Velázquez)

Cc: zeael@… added

Has duplicate #38459.

comment:13 Changed 6 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:14 Changed 5 years ago by mathsmac@…

Cc: mathsmac@… added

Cc Me!

comment:15 Changed 4 years ago by larryv (Lawrence Velázquez)

Resolution: fixed
Status: newclosed

Updated to 0.10.0 in r132827, works fine with our current Automake 1.15.

Note: See TracTickets for help on using tickets.